1

I'm attempting to increase my resolution to 1440p on an existing CentOS VM. Currently, the display options only show up to 1080p under CentOS (guest OS, screenshot here), but I am able to run 1440p on Windows 7 (host OS, screenshot here). Virtual Box Linux guest additions 4.3.20 are installed (the latest version). I looked around already for suggestions on fixing this and found some people suggesting that I manually include the resolution. I ran the following commands with results included:

# cvt 2560 1440
2560x1440 59.96 Hz (CVT 3.69M9) hsync: 89.52 kHz; pclk: 312.25 MHz
Modeline "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync

# xrandr
Screen 0: minimum 64 x 64, current 5760 x 1080, maximum 16384 x 16384
VBOX0 connected 1920x1080+1920+0 0mm x 0mm
   1920x1080      60.0*+
   1600x1200      60.0  
   1440x1050      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.0  
   640x480        60.0  
VBOX1 connected 1920x1080+0+0 0mm x 0mm
   1920x1080      60.0*+
   1600x1200      60.0  
   1440x1050      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.0  
   640x480        60.0  
VBOX2 connected 1920x1080+3840+0 0mm x 0mm
   1920x1080      60.0*+
   1600x1200      60.0  
   1440x1050      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.0  
   640x480        60.0  

# xrandr --addmode VBOX0 "2560x1440_60.00"
xrandr: cannot find mode "2560x1440_60.00"

I'm not sure what steps to take at this point to increase the resolution. I'm using displayport on the monitors, the latest version of VirtualBox, and CentOS 6.6 64-Bit. Anything to point me in the right direction would be helpful. Thanks.

UPDATE: I found further information that I needed another command, so I tried the following with no success:

# xrandr --newmode "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync

# xrandr --addmode VBOX0 "2560x1440_60.00"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  34
  Current serial number in output stream:  35
0

I finally solved the problem, so I wanted to share the steps I took to fix it.

The issue that I was stuck on was that the VirtualBox video settings were limiting me to 1080p or less, so I had to run the following command in my host OS (Windows 7). Do this while the VM is offline.

> VBoxManage setextradata "Web Dev" CustomVideoMode1 2560x1440x32

I booted the VM and reentered the following (new modes don't stay between boots):

# xrandr --newmode "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync

# xrandr --addmode VBOX0 "2560x1440_60.00"
# xrandr --addmode VBOX1 "2560x1440_60.00"
# xrandr --addmode VBOX2 "2560x1440_60.00"

Finally, I opened up the Display Preferences (System->Preferences->Display), and the new resolution was listed.

Note that I ran the 'xrandr --addmode' for each monitor, where VBOX0 is the name of the monitor as shown in the Display Preferences.

Hope that helps!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.