0

when i enter :

 sudo apt-get upgrade

I get the following messages:

 Reading package lists... Done 
 Building dependency tree        
 Reading> state information... Done 
 Calculating upgrade... Done 
 The following packages have been kept back:   
 libavcodec54 libavdevice53 libavformat54 
 0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

output for :-

sudo apt-cache rdepends libavcodec54

here :-

libavcodec54 Reverse Depends: libavcodec54:i386 libavcodec54:i386 libavcodec-extra-54:i386 libavcodec-extra-54:i386 |vlc-nox |libopenscenegraph99 |libavformat54 |libavfilter3 |libavdevice53
libavcodec-extra-54 libavcodec-extra-54 |libavcodec-dev |libavcodec-dev |libav-tools |libav-dbg |gstreamer1.0-libav |ffmpegthumbs |audacity libavcodec54:i386 libavcodec54:i386
libavcodec-extra-54:i386 libavcodec-extra-54:i386 |xjadeo |transcode |idjc |zoneminder |yorick-av |xpra |xmms2-plugin-avcodec |xbmc-bin |vlc-nox |tupi |survex-aven |squeezelite-pa |squeezelite |spek |silan |shotdetect |qutecom |python-renpy |python-libavg |performous |paraview |mpv |mplayer2 |mplayer-gui |mplayer |mpd |motion |moc-ffmpeg-plugin |miro |mencoder |lynkeos.app |lives |lightspark-common |libxine2-x |libxine2-ffmpeg |libxine1-ffmpeg |libwxsvg0 |libvxl1.17 |libvtk6 |libvtk5.8 |libvisp2.8 |libquicktime2 |libqmmp-misc |libphash0 |libopenscenegraph99 |libopencv-highgui2.4 |libopal3.10.10 |libmrpt-hwdrivers1.0 |libmrpt-dbg |libmlt6 |libmediastreamer-base3 |libk3b6-extracodecs |libjitsi-jni |libgmerlin-avdec1 |libffms2-3 |libffmpegthumbnailer4 |libchromaprint0 |libchromaprint-tools |libavifile-0.7c2 |libavformat54 |libavfilter3 |libavdevice53
libavcodec-extra-54 libavcodec-extra-54 |libavcodec-dev |libavcodec-dev |libavbin0 |libav-tools |libav-dbg |libaubio4 |libasound2-plugins-extra |kino |kid3-core |jmdlx |hedgewars |harvid |handbrake-cli |handbrake |guvcview |gstreamer1.0-libav |gpac-modules-base |goldendict |gnash-common |fuse-emulator-utils |forked-daapd |ffmpegthumbs |ffmpeg2theora |ffdiaporama |dvswitch |dvdstyler |dvbcut |dff |cantata |bombono-dvd |blender |bino |audacious-plugins |aubio-tools |amide |acoustid-fingerprinter |ffmpegthumbs libavcodec-extra-54:i386 libavcodec-extra-54:i386
libavcodec54:i386 libavcodec54:i386 |libavfilter3
libavcodec-extra-54 libavcodec-extra-54 |libavformat54 |libavdevice53 |ffmpeg-dbg |libavcodec-dev |libavcodec-dev |ffmpeg |simplescreenrecorder

for :-

sudo apt-cache rdepends libavdevice53

Here :-

libavdevice53 Reverse Depends: libavdevice53:i386
libavdevice53:i386 libopenscenegraph99 libavdevice-extra-53
libavdevice-dev libav-tools libav-dbg libavdevice53:i386
libavdevice53:i386 libopenscenegraph99 libmlt6
libavdevice-extra-53 libavdevice-dev libav-tools libav-dbg
ffmpeg2theora blender bino libavdevice53:i386
libavdevice53:i386 libavdevice-extra-53 ffmpeg-dbg
libavdevice-dev ffmpeg

for :-

sudo apt-cache rdepends libavformat54

here :-

libavformat54 Reverse Depends: libavformat54:i386
libavformat54:i386 vlc-nox nepomuk-core-ffmpegextractor
libopenscenegraph99 libkfilemetadata4 libavformat-extra-54
libavformat-dev libavfilter3 libavdevice53 libav-tools
libav-dbg gstreamer1.0-libav ffmpegthumbs audacity
libavformat54:i386 libavformat54:i386 xjadeo transcode idjc
zoneminder yorick-av xbmc-bin vlc-nox tupi survex-aven
squeezelite-pa squeezelite spek silan shotdetect
python-renpy python-libavg performous paraview
nepomuk-core-ffmpegextractor mpv mplayer2 mplayer-gui mplayer mpd motion moc-ffmpeg-plugin miro mencoder mediatomb-common lynkeos.app lives lightspark-common libwxsvg0 libvxl1.17
libvtk6 libvtk5.8 libvisp2.8 libqmmp-misc libphash0
libopenscenegraph99 libopencv-highgui2.4 libmrpt-hwdrivers1.0
libmrpt-dbg libmlt6 libkfilemetadata4 libk3b6-extracodecs
libjitsi-jni libgmerlin-avdec1 libffms2-3 libffmpegthumbnailer4 libdlna0 libchromaprint-tools libavifile-0.7c2
libavformat-extra-54 libavformat-dev libavfilter3 libavdevice53 libavbin0 libav-tools libav-dbg libaubio4 kradio4 kino
kid3-core hedgewars harvid handbrake-cli handbrake
gstreamer1.0-libav gpac-modules-base goldendict gnash-common
gmerlin-encoders-ffmpeg fuse-emulator-utils forked-daapd
ffmpegthumbs ffmpeg2theora ffdiaporama dvdstyler dvbcut dff cmus-plugin-ffmpeg cantata bombono-dvd blender bino
audacious-plugins aubio-tools acoustid-fingerprinter
libkfilemetadata4 ffmpegthumbs libavformat54:i386
libavformat54:i386 libavfilter3 libavformat-extra-54
libavdevice53 ffmpeg-dbg libavformat-dev ffmpeg
simplescreenrecorder

for :-

sudo apt-get install libavcodec54 libavdevice53 libavformat54

here :-

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: libavdevice53 : Depends: libavcodec54 (>= 7:1.2.5~) but 6:9.16-0ubuntu0.14.04.1 is to be installed or libavcodec-extra-54 (>= 7:1.2.5~) but it is not going to be installed Depends: libavfilter3 (>= 7:1.2.5~) but it is not going to be installed libavformat54 : Depends: libavcodec54 (>= 7:1.2.5~) but 6:9.16-0ubuntu0.14.04.1 is to be installed or libavcodec-extra-54 (>= 7:1.2.5~) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

I am using linux mint 17.1 cinnamon.

  • sudo apt-get dist-upgrade But please read into it before executing See: askubuntu.com/questions/601/… I found the answer by searching for "The following packages have been kept back" – jmunsch Jan 11 '15 at 3:36
  • If you meant dist-upgrade jmunsch is correct. If you meant upgrade see my answer. – eyoung100 Jan 11 '15 at 3:44
  • What is the output of apt-get intall libavcodec54 libavdevice53 libavformat54? Please paste into the question. – Faheem Mitha Jan 11 '15 at 12:07
  • please look !!! – Ashu_FalcoN Jan 11 '15 at 13:00
  • What does apt-get --simulate dist-upgrade say? Does it want to install or remove any packages? – Mark Plotnick Jan 12 '15 at 2:15
1

We need to see what package depends on those packages. To do so, issue:

sudo apt-cache rdepends libavcodec54
sudo apt-cache rdepends libavdevice53
sudo apt-cache rdepends libavformat54

My hunch is vlc. If that is the case, issue:

sudo apt-get purge vlc

then try upgrading then reinstall vlc

  • nope still problem exits !!! – Ashu_FalcoN Jan 11 '15 at 3:46
  • should i provide output for :- 1) sudo apt-cache rdepends libavcodec54 2) sudo apt-cache rdepends libavdevice53 3)sudo apt-cache rdepends libavformat54 – Ashu_FalcoN Jan 11 '15 at 3:48
  • Yes provide output in your Original Post. – eyoung100 Jan 11 '15 at 3:59
  • updated please look !! – Ashu_FalcoN Jan 11 '15 at 4:05
  • After reading that list and seeing Why use apt-get upgrade instead of apt-get dist-upgrade?, I think you better do a dist-upgrade. – eyoung100 Jan 11 '15 at 4:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.