5

I'm trying to get some flavour of Linux going on an old iMac G4/800 with NV11 video hardware. So far I've tried Ubuntu 14.04, Ubuntu 12.04 and Debian 7.7. All face the following common issues:

  • I cannot get nouveau to work - at all. The console gets rendered OK, but once nouveau is initialized, the screen 'fades to white' and I get a hard lockup - no Ctrl-Alt switches, no blind command-line stuff, nothing. This applies to both the 'current' nouveau included with the above distributions and the latest-released nouveau 1.0.11 (which I installed manually.)

  • I can boot to command line if I don't load nouveau (i.e. use nomodeset or nouveau.modeset = 0 as yaboot parameters).

  • fbdev and vesafb give a low-colour utterly unusable desktop.

  • The old Mac OS X 10.2 that was on the machine worked flawlessly so I don't think there's a hardware problem.

Focusing on Debian 7.7:

  • There is a package for 'xserver-xorg-video-nv' in the /oldstable archives.

EDIT: I can't install the xserver-xorg-video-nv package from oldstable without a lot of risk, as it seems that there are conflicts with the newer xserver-xorg-core / xserver-video-abi-6.0 which is installed. So - is there a way to get nouveau working with NV11, or is there a known-good way to get vesafb going on this card to present a useable desktop?

EDIT #2: vesafb doesn't seem to work, as fbdev seems to be misidentifying the hardware. I try passing 'video=vesafb:1024x768-16@60' and end up with a psychedelic low-color mouse pointer and this in the Xorg.0.log:

(==) FBDEV(0): Creating default Display subsection in Screen section "Default Screen Section" section for depth/fbbpp 8
(==) FBDEV(0): Depth = 8, (==) framebuffer bpp 8
(==) FBDEV(0): Default visual is PseudoColor
(==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
(==) FBDEV(0): hardware: 0Ffb NVDA,NVMAC (video memory: 768kb)
2

My current solution, for the record:

The only way I was able to get the display going on this machine was:

  • blacklist nouveau
  • add the oldstable repositories to sources.list
  • apt-get remove the entire Xorg subsystem (and gdm)
  • apt-get -t oldstable install the previous revision's Xorg subsystem (including the nv driver) and xfce4

(I opted to go with xfce4 given the age of the hardware)

iMac G4 running Debian 7.7 and xfce4

X starts up, loads the nv driver and ... now I have a GUI.

It's a bit of a compromise but at least parts of the operating system are up-to-date.

-2

There is a way to install proprietary drivers that supposed to work better:
Go http://www.nvidia.com/Download/index.aspx?lang=en-us.
In Product Type select Legacy.
In Product Series select GeForce 2 MX Series
Click Search
Download *.run file.
Set executable options for it chmod +x *.run
Run it.

  • 3
    Proprietary drivers are not provided for PowerPC. I'm using an iMac G4. I have had good success with them on Intel PCs though. – Adam Lawrence Jan 10 '15 at 18:08
  • I had same problems with one my "new" nvidia video hardware. So, any nouveau solution gave me only fbdev ( just like in your case ) but X11 gave me only white screen ( just like yours ). And my solution was installing proprietary drivers. So, could you please explain why you can't install those drivers on your PowerPC? – linuser Jan 10 '15 at 18:17
  • 1
    The proprietary drivers rely on a binary blob which is only compiled for x86 architectures. – Adam Lawrence Jan 10 '15 at 18:20
  • The webpage you cited confirms what I already knew - only x86 and x64 drivers are provided by nVidia. No powerpc. – Adam Lawrence Jan 10 '15 at 18:30
  • 2
    Appreciate the effort but clearly you misunderstand. nVidia has never released a driver for PowerPC - binary or source. Other than generic drivers like veasfb, there are exactly two choices for PowerPC - nouveau and nv. That's all. – Adam Lawrence Jan 10 '15 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.