12

I am running kali linux, which has gnome. I just updated with

apt-get update && apt-get upgrade

and that completed without incident, only a little while after did I realise that my bottom taskbar was missing(well technically just blank(black)). The one where running programs are displayed as well as the 4 buttons that allow switching between workspaces. I have searched around for the last hour, and tried a few things, such as

gconftool --recursive-unset /apps/panel && killall gnome-panel

and a couple of variations thereof.

Nothing has worked so far. I also tried:

apt-get build-dep gnome-panel

which installed a ton of stuff to my surprise... but still, no fix.

If I type gnome-panel into the terminal I get the message:

Cannot register the panel shell: there is already one running.

So clearly, it's not gone(anyway the top bar with menus and shutdown options etc. is still there), it's just the bottom bar... I also noticed that while I say it's missing, it's technically still there, albeit just a black unresponsive bar across the bottom of the screen. So I guess my real question is, why is it not showing anything? And can anybody please help me out?

8 Answers 8

13

It turns out that for some reason the settings for my bottom panel(taskbar) had been altered. To access the menu for the panels(top & bottom bars), I needed to hold Alt and then Right-click. This opened a little menu where I could select Add to panel... which opens another menu of things you can add to the taskbar. What I needed to add was 'Windows List', which solved my problem.

1
  • I had to explicitly enable the "Window List" under Extensions in the gnome-tweaks application.
    – Attila
    Commented Apr 22, 2021 at 14:36
4
  1. Open an application named Tweaks.
  2. Go to Extensions.
  3. Enable window list.
  4. Done
1
  • You can also search for Extensions then you enable the extensions you want as he mentioned above
    – Bercove
    Commented Oct 11, 2023 at 7:46
3

On the latest version of Kali 2.x, I had the same exact issue. Alt + Right Click didn't do anything, but if you do the following it gets out of Kiosk mode

right click

select applications -> settings -> panel

it will say there is no panel running and are you sure you want to start one.. I clicked execute and it stopped running kiosk mode.

1

In case your right click doesn't work (mine didn't on the desktop), do this:

  1. Press Alt+F2

  2. In the "Application Finder" search box, enter "Panel"

  3. Follow what Erik said
1

This command helped me to get back side toolbar:

apt-get install gnome-core kali-defaults kali-root-login desktop-base
1

For Ubuntu running Gnome 40 you need to toggle the Ubuntu AppIndicators toggle in Extensions.

0

Follow the steps:

  • gnome-tweak-tool → Extensions → Window List
0

100 PERCENT SOLUTION.

Click on "Applications" (on the TOP bar, just beside with "Places" option) → then click on "Activities overview" (at the end of the bottom of the options list) → then go to in the "Dash to dock setting" with the help of right-click on "extreme right option" → then go to "Position and size" option on the top → "Intelligent Autohide" → Disable it.

Your problem has been solved :)

1
  • 1
    This "100 PERCENT SOLUTION" is not working for me.
    – Attila
    Commented Apr 22, 2021 at 14:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .