1

I am using VirtualBox on a Macbook Pro running Yosemite.

My linux guests sometimes consume 100% of the host CPU (viewed in Activity Monitor) even though the guest is idle.

Why is the host CPU utilization so high and how can this be fixed?

3

From the VirtualBox manual:

12.4.1. Linux guests may cause a high CPU load

Some Linux guests may cause a high CPU load even if the guest system appears to be idle. This can be caused by a high timer frequency of the guest kernel. Some Linux distributions, for example Fedora, ship a Linux kernel configured for a timer frequency of 1000Hz. We recommend to recompile the guest kernel and to select a timer frequency of 100Hz.

Linux kernels shipped with Red Hat Enterprise Linux (RHEL) as of release 4.7 and 5.1 as well as kernels of related Linux distributions (for instance CentOS and Oracle Linux) support a kernel parameter divider=N. Hence, such kernels support a lower timer frequency without recompilation. We suggest to add the kernel parameter divider=10 to select a guest kernel timer frequency of 100Hz.

  • Running cpufreq-set -g powersave on the guest machine may help keep CPU frequencies down when the guest machine is idle. – amphetamachine Jan 9 '15 at 18:16
  • @amphetamachine, no, since the guest can't change the frequency of the real cpu. – psusi Jan 9 '15 at 23:18
  • Although this is the only suggestion I found for my issue, it hasn't resolved the problem. I have confirmed that my kernel (3.16.0-4) is using CONFIG_HZ=250. – Jon Nalley Feb 9 '15 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.