0

I am trying to install Math::CDF in perl I tried both cpan -i Math::CDP and install from downloaded files both end up in error after enter make install:

Running make install
make[1]: Nothing to be done for `all'.
Files found in blib/arch: installing files in blib/lib into architecture dependent library tree
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ERROR: Can't create '/opt/local/lib/perl5/site_perl/5.16.3/darwin-thread-multi-2level/Math'
mkdir /opt/local/lib/perl5/site_perl: Permission denied at /opt/local/lib/perl5/5.16.3/ExtUtils/Install.pm line 494.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 at -e line 1.
make: *** [pure_site_install] Error 13
  CALLAHAN/Math-CDF-0.1.tar.gz
  /usr/bin/make install  -- NOT OK

Here is the version of the perl and the path:

bash-4.2$ which make
/usr/bin/make
bash-4.2$ which perl
/opt/local/bin/perl
bash-4.2$ perl -v

This is perl 5, version 16, subversion 3 (v5.16.3) built for darwin-thread-multi-2level

2
  • Is it anything more than a straightforward permissions error? are you running the install as root? Jan 9, 2015 at 3:45
  • @steeldriver I think every time I tried to use cpan, the install process was killed by can't create folders in darwin-thread-multi-2level. I feel they should ask me for password to make folders but there is no place to enter password, is this the reason?
    – Karli
    Jan 12, 2015 at 17:48

1 Answer 1

1

This problem may be because you don't have the permission to write onto those files. You can try to install it locally.

perl Makefile.PL PREFIX=/path/to/home/folder

then you can run:

make
make install

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .