4

I am running Linux Mint 17.1 Rebecca, with Cinnamon 2.4.5. I have a double screen: my laptop's¹ screen, and another (Dell) screen, both with resolution 1920×1080. I have a strange bug (maybe is it a feature, that I do not know how to deactivate!), and I have difficulties to explain it, so please tell me if you cannot make sense of my explanations.

Let me precise that my external screen is the primary screen, and the laptop screen the secondary screen. Also, the laptop screen is on the right of the external screen. The bug occurs with mouse moves:

  1. When I log in, everything is displayed well. The mouse is on the primary screen.
  2. I move the mouse to the right on the external screen, up to the frontier between both screens, everything works well.
  3. Then, if I continue to the right (going now to the laptop screen), the laptop screen displays what it should, but the external screens begins to display what is on the laptop screen also. What is displayed on the external screen begins to "slide to the left" (the left part is not visible anymore) and on its right, I see the same thing as the left part of the laptop screen.
  4. If I go all the way long to the right of the laptop screen, I end up with two identical screens, both displaying what the laptop is supposed to display.
  5. Now if I make the inverse path, going to the left, nothing is going on as long as the mouse is on the laptop screen, and when it attains the external screen, the external screen begins to slide again, to the right this time, to display what it should.
  6. When the mouses attains the left edge of the external screen, I am back with the correct display.

I wanted to put here a screenshot, but screenshots are (also...) working strangely, it is probably related.

Do you have any clues?

¹ Dell Precision M4700

  • Remove screen tag. It's for GNU Screen terminal multiplexer. – Arkadiusz Drabczyk Jan 12 '15 at 19:58
  • Did you find a solution to this? I'm having the same issue. – preds Jan 5 '16 at 3:41
  • I am not having the issue anymore. I am not sure how it disappeared. I do think the bug was removed by some update in Cinnamon some time ago. If your system is not up-to-date, I urge you to update to see if the bug is removed. (Since I changed my laptop a few weeks ago, I cannot perform tests anymore.) – Bruno Jan 5 '16 at 14:25
  • I've got this occurring with Mint 17.3. I have two cards, on board and a NVidia - one display connected to each. If anyone figures this out... – I Stevenson Mar 17 '16 at 1:28
1

I had the same problem in Linux Mint 18 Sara,

I hooked up my New build computer initially to my 1080i HD TV and didn't have problems until installing steam. suddenly my desktop no longer fit in my TV screen. My desktop was bigger than my TV and my mouse would adjust the screen left to right and top to bottom as i moved it. I spent an entire evening trying to figure this out until I was so angry i was ready to go back to windows. It was like I was zoomed in?

I believe in giving credit where it is due I The next morning while at work my wife called me and told me she fixed it, and I said thank you followed with how? I hope this simple fix helps someone out their like me who forgets to start with the simple solutions instead of diving straight into the terminal or checking drivers and graphic card settings.

My wife fixed the problem by going to - MENU - Preferences - ACCESSIBILITY -

Then she turned ZOOM OFF

  • I didn't have the original problem, but your answer popped up on a google search, and the solution wasn't in that menu but using Alt + mouse wheel, as described at ubuntuforums.org/… - so it's definitely off-topic, but it could help someone else who stumbles upon it – Josip Rodin Mar 26 at 13:19
0

I had the same issue on ubuntu with gnome 3, it was fixed with using new drivers of nvidia (375.20)
http://i.imgur.com/5F6mEgc.png

  • It would be helpful to the OP to understand if you could explain. – Mongrel Nov 30 '16 at 6:40
  • I didn't get what do you mean? "Helpful to OP" I suppose that this is driver problem and in nvidia drivers 375.20 it was fixed. – AlexKutsan Dec 4 '16 at 18:53
0

I occaisionally had the same issue on Linux Mint 18 Sarah Cinnamon v3.0.7, with cards on board and an nvidia.

What solved it for me was changing driver from xserver-xorg-video-nouveau to nvidia-375 for the nvidia driver in Driver mananger.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.