3

I have a laptop with Linux Mint 17 installed. Whenever I am typing and the touchpad is enabled, successive keystrokes are being interrupted. For example, if I would try to type 'paragraph', it could result in 'paraph', due to three keystrokes being ignored.

This only occurs when the touchpad is enabled, and when my palm is resting on the touchpad. If I avoid touching my touchpad, this does not occur. Mouseclicks with touchpad are disabled (e.g. tapping the touchpad does not work). The interrupting occurs both with and without palm detection ('disable touchpad when typing').

Executing cat /proc/bus/input/devices detects the following touchpad:

I: Bus=0011 Vendor=0002 Product=000e Version=0000
N: Name="ETPS/2 Elantech Touchpad"
P: Phys=isa0060/serio2/input0
S: Sysfs=/devices/platform/i8042/serio2/input/input10
U: Uniq=
H: Handlers=mouse0 event5 
B: PROP=1
B: EV=b
B: KEY=6420 30000 0 0 0 0
B: ABS=260800011000003

Can anyone help me get this to work? My goal is to be able to type with an enabled touchpad, without the touchpad interfering with my typing.

Please tell me what I should do or what information I should provide. Thank you!

--

Output of commands:

egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices
N: Name="ETPS/2 Elantech Touchpad"

synclient -l | grep Palm
PalmDetect              = 0
PalmMinWidth            = 10
PalmMinZ                = 200
  • 2
    Have you tried utility gpointing-device-settings? There you can set up "palm detection" options. – kirill-a Jan 8 '15 at 11:32
  • It helps, but does not fix the problem. When I add palm detection, it still occurs at the start (when the palm is not yet detected). Once the palm is detected I can type freely. This process takes a while (1-2 sec) to set in. – Rex Jan 8 '15 at 12:34
  • 1
    What's the output of synclient -l | grep Palm? – Fabby Oct 13 '15 at 23:26
  • 1
    Please, state your hardware. What is the output of egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices? If no output, please go manually through, and find pad and state the relevant entry. - - What is your Window manager? Gnome? Version? - - In the meantime, you can disable some functions of touchpad, etc tapping, if too many interruptions etc here askubuntu.com/q/193376/25388 Debian Touchpad documentation here wiki.debian.org/SynapticsTouchpad – Léo Léopold Hertz 준영 Oct 9 '17 at 21:24
  • Hi Leo, I've added the output to the question. Even though it's two years old the problem still persists. Tapping is indeed disabled, thanks for the link. – Rex Oct 11 '17 at 16:08
1

This thread on Askubuntu Provides a good set of answers and experiences that might help you. I haven't tried it myself yet, but certainly will. Untill I read your question I hadn't realised that there was anything called PalmDetection, so have given your question an up vote.

BTW I noticed from your output from synclient -l |grep Palm PalmDetect=0 which is not enabled.

  • You can enable PalmDetection in gpointing-device-settings. It however does not exist in 16.04 yet. I do not have it in my system, so I get synclient -l | grep Palm the output PalmDetect = 0; PalmMinWidth = 10; PalmMinZ = 200;. It would be great to know what is the good configuration for its detection without gpointing-device-settings in different configurations. I think you can configure it manually too. – Léo Léopold Hertz 준영 Jun 13 '16 at 9:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.