I decided to move my /home directory to a separate parition. But, since I am using more than one linux distro, I want to separate the /home directories as follows:


After copying all the neccessary files to this folder, I changed the /etc/fstab to mount the new /home location as the default home drive

/dev/sdax    /homedrive ext4 nodev,nosuid 0 2
/homedrive/debian /home bind default,bind 0 0

Now, as far as I can see while starting up debian, it is mounting the folder properly, but while I try to login it gives an error:

Could not update ICEauthority file /home/user-name/.ICEauthority

And after closing that message I get:

There is problem with the configuration server (/usr/libexec/gconf-sanity-check-2 ...

What's going wrong?

  • Are the permissions of the home directory set properly? ls -l /home/user-name – beav_35 Aug 1 '11 at 5:53
  • Yes, I think. The permission is 644 – Starx Aug 1 '11 at 6:03
  • How about the files in the directory, specifically .ICEauthority? And is the owner/group set properly too? – beav_35 Aug 1 '11 at 6:14
  • I am not sure about that? How to check it and change, since I am not able to log in. – Starx Aug 1 '11 at 7:41
  • What are the permissions of the .ICEauthority file? Could you also post the output of ls -la /home/? – rozcietrzewiacz Aug 1 '11 at 7:42

You can login to a terminal as root (on Debian you should have set a root password when you installed) by pressing [Ctrl]+[Alt]+[F1] once your system have booted. You can then check that the permissions is correct with this commenad

ls -ld /home/user/


ls -l /home/user/.ICEauthority

change ownership with

chown user: /home/user

and permissions with

chmod mode /home/user/file

Permissions on your home folder should be 755 or 750 and on the .ICEauthority file is should be 600.


I followed this tutorial. Wrote the following command and it worked.

chown -R username:username /home/username
chmod 644 /home/username/.dmrc
chmod 644 /home/username/.ICEauthority

You seem to have copied the home directories without properly preserving the ownerships of files/folders. From info cpio:

     Do not change the ownership of the files; leave them owned by the
     user extracting them.  This is the default for non-root users, so
     that users on System V don't inadvertantly give away files.  This
     option can be used in copy-in mode and copy-pass mode

So you should repeat the operation as root - either the same way you did, or using the simpler cp -a command.

edit: I see you've just solved it. So it confirmed the issue was with ownerships.

  • Should I include --no-preserve-owner in the command I wrote to copy the files? – Starx Aug 2 '11 at 8:01
  • @Starx No no no - this should NOT be used in your case. But it is the default option for non-root users - that is why I posted it here. – rozcietrzewiacz Aug 2 '11 at 8:50

I sincerely hope you're not creating data directories on the dev filesystem!

/dev/sdax    /homedrive ext4 nodev,nosuid 0 2
/homedrive/debian /home bind default,bind 0 0

OK so it looks like you're not - but its still a strange way to set up the filesystem. I assume you've got 3 different directories set up on the same filesystem...

A better way to solve this would be to use different symlinks in each distro to the location of /home

mount /dev/sdax /homedrives
cp -R -p /home /homedrives/${currentdistro}
rm -r -f /home
ln -s /homedrives/${currentdistro} /home
  • 2
    mount bind or sym-links accomplish exactly the same in this case.. I can't see how one should be better than the other! – LassePoulsen Aug 1 '11 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.