0

I started Kali Linux this morning and everything was like the days before; the cursor was there. Then I turned it off, started again and boom -> No cursor. I'm using Windows 8.1 and Kali Linux is running with VirtualBox.

  • 1
    Have you checked Settings -> System -> Pointing Device set to ps2 mouse? – kirill-a Jan 6 '15 at 18:54
  • It's been set to "USB Tablet" I can't change it. – Henrik Jan 6 '15 at 19:20
  • Why can't you? Have you turned off the virtual machine? – kirill-a Jan 6 '15 at 19:49
  • I have no idea. I just can't edit those settings. Where can I see if I've turned off the virtual machine? If you mean the actual Kali Linux program yes I've done that. – Henrik Jan 6 '15 at 20:22
  • Nevermind I got it. Thank you so much you saved my arse! – Henrik Jan 6 '15 at 20:35
4

Go to Settings -> System -> Pointing Device and set to ps2 mouse. Be sure that machine is powered off to change settings.

0

Well, it turns out there is a simple solution. Right-click the VM from the list, click Settings, click System on the left menu, and change Pointing Device to "USB Tablet" instead of "PS/2 Mouse".

For some reason, all my LFS VM's defaulted to "USB Tablet" but CentOS VM's defaulted to "PS/2 Mouse". So my guess is the built-in templates (or whatever they are called) have that wrong. When creating a new VM, if I type in "LFS", I get Type "Linux" and Version "Linux 2.6/3.x (64-bit)" but if I type in "CentOS", I get Type "Linux" and Version "Red Hat (64 bit)". So, in my opinion, the "Red Hat (64 bit)" template should be changed to set Pointing Device to "USB Tablet".

References: https://www.virtualbox.org/ticket/3506 https://www.virtualbox.org/ticket/6642 https://www.virtualbox.org/manual/ch09. ... se-capture

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.