0

This is my first post to this website. I this that my question is related to serverfault cause it is related to ethernet communication issue. If you disagree please let me know what is the appropriate place to move this post to. Thanks.

I am using USB3 to GigE converter - since I don't have GigE on my linux board. My problem is after connecting to an IP camera. It works for sometime and I am able to receive images but then it stops after one or two minutes. After it stops I cannot ping anything and I can see there are error in rx packets.
Here is my ifconfig before connecting to the camera:

ifconfig
eth1      Link encap:Ethernet  HWaddr 00:13:3b:99:28:56  
          inet addr:192.168.0.117  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::213:3bff:fe99:2856/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:4000  Metric:1
          RX packets:102 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:29172 (29.1 KB)  TX bytes:6614 (6.6 KB)

and here is the same after connecting to the camera and stops responding:

ifconfig
eth1      Link encap:Ethernet  HWaddr 00:13:3b:99:28:56  
          inet addr:192.168.0.117  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::213:3bff:fe99:2856/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:4000  Metric:1
          RX packets:137338 errors:1604 dropped:0 overruns:0 frame:0
          TX packets:3662 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:274563593 (274.5 MB)  TX bytes:287885 (287.8 KB)

Clearly there are error in RX packets, I am not sure why. Here is the ethtool eth1 output:

ethtool eth1
Settings for eth1:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  Not reported
    Advertised pause frame use: No
    Advertised auto-negotiation: No
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 3
    Transceiver: internal
    Auto-negotiation: off
Cannot get wake-on-lan settings: Operation not permitted
    Current message level: 0x00000007 (7)
                   drv probe link
    Link detected: yes

migrated from serverfault.com Jan 6 '15 at 16:52

This question came from our site for system and network administrators.

  • Offtopic on there, more for the superuser section I think but at first I would suggest a dedicated NIC if the cam is network intensive. – yagmoth555 Jan 6 '15 at 16:48
  • Could you do some packet sniffing to try and figure out where they're coming from? Choose one of these and try and capture the moment when this happens, it might help us debug the issue a bit more efficiently. sectools.org/tag/sniffers – Chip Wolf Jan 6 '15 at 17:01
1

I would take a look at the MTU. It may be a USB3/GigE thing, but change it to 1500 and attempt to continue:

ifconfig eth1 mtu 1500

Edit: A note - This is a temp setting which will not persist through a reboot.

  • it didnt help :( – Samer Jan 6 '15 at 17:29
  • can you give output of dmesg? The best time to do this would be right after the issue happens. – Justin Edmands Jan 6 '15 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.