0

I want to use box-cutter/debian77 but when I try

vagrant box add box-cutter/debian77 https://atlas.hashicorp.com/box-cutter/debian77

I get

Downloading box from URL: https://atlas.hashicorp.com/box-cutter/debian77
Extracting box...e: 0/s, Estimated time remaining: --:--:--)
The box failed to unpackage properly. Please verify that the box
file you're trying to add is not corrupted and try again. The
output from attempting to unpackage (if any):

bsdtar: Error opening archive: Unrecognized archive format

what is wrong? I have instlalled all archivers (unar, bsdtar, bzip2,...)

Or where can I download the image manually?

I use Vagrant 1.4.3 on Ubuntu 14.10. the same command works on a friend using arch and on debian wheezy too

1

The URL you're providing is that of a web page I think, not a tarball. You just need to do this:

vagrant box add box-cutter/debian77
  • Then I get This command was not invoked properly. The help for this command is available below. Usage: vagrant box add <name> <url> [--provider provider] [-h] – rubo77 Jan 5 '15 at 22:22
  • Vagrant 1.7.1 didn't ask for the URL. What version are you using? – EricM Jan 5 '15 at 22:25
  • vagrant 1.4.3 on ubuntu – rubo77 Jan 5 '15 at 22:26
  • This seems to indicate 1.7 is a minimum requirement. Have you tried: vagrant init box-cutter/debian77 ; vagrant up or vagrant box add box-cutter/debian77 https://atlas.hashicorp.com/box-cutter/boxes/debian77/versions/1.0.8/providers/virtualbox.box? – EricM Jan 5 '15 at 22:43
  • Ok, I will try a newer version: askubuntu.com/questions/569339/… – rubo77 Jan 5 '15 at 22:45
1

You need to install a newer vagrant version.

I tried vagrant 1.6.5 and it works.

It seems 1.5 is required, see: https://github.com/coreos/coreos-vagrant/issues/112#issuecomment-43425522

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.