0

I am very confused as to why I cannot connect to my fedora server from my desktop through filezilla.

I think I have added the service to the firewall (though when I use firewall-cmd --list-services it does not show...) and the server is started, I can telnet into it from the 192 IP locally but from my desktop it just says

Status: Connecting to 192.168.1.113:21...
Error:  Connection timed out
Error:  Could not connect to server

is my configuration incorrect?

[root@localhost ~]# cat /etc/redhat-release
Fedora release 21 (Twenty One)

[root@localhost /]# netstat -ntulp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN      981/smbd
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN      981/smbd
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      838/sshd
tcp6       0      0 :::443                  :::*                    LISTEN      1452/httpd
tcp6       0      0 :::445                  :::*                    LISTEN      981/smbd
tcp6       0      0 :::9090                 :::*                    LISTEN      1/systemd
tcp6       0      0 :::139                  :::*                    LISTEN      981/smbd
tcp6       0      0 :::80                   :::*                    LISTEN      1452/httpd
tcp6       0      0 :::21                   :::*                    LISTEN      1559/vsftpd
tcp6       0      0 :::22                   :::*                    LISTEN      838/sshd
udp        0      0 0.0.0.0:68              0.0.0.0:*                           958/dhclient
udp        0      0 192.168.1.255:137       0.0.0.0:*                           840/nmbd
udp        0      0 192.168.1.113:137       0.0.0.0:*                           840/nmbd
udp        0      0 0.0.0.0:137             0.0.0.0:*                           840/nmbd
udp        0      0 192.168.1.255:138       0.0.0.0:*                           840/nmbd
udp        0      0 192.168.1.113:138       0.0.0.0:*                           840/nmbd
udp        0      0 0.0.0.0:138             0.0.0.0:*                           840/nmbd
udp        0      0 0.0.0.0:11320           0.0.0.0:*                           958/dhclient
udp6       0      0 :::18941                :::*                                958/dhclient

vsftpd.conf

# Example config file /etc/vsftpd/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=YES
#
# Uncomment this to allow local users to log in.
# When SELinux is enforcing check for SE bool ftp_home_dir
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# When SELinux is enforcing check for SE bool allow_ftpd_anon_write, allow_ftpd_full_access
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/xferlog
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
xferlog_std_format=YES
#log_ftp_protocol=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd/banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
#chroot_local_user=YES
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd/chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode and
# listens on IPv4 sockets. This directive cannot be used in conjunction
# with the listen_ipv6 directive.
listen=NO
#
# This directive enables listening on IPv6 sockets. By default, listening
# on the IPv6 "any" address (::) will accept connections from both IPv6
# and IPv4 clients. It is not necessary to listen on *both* IPv4 and IPv6
# sockets. If you want that (perhaps because you want to listen on specific
# addresses) then you must run two copies of vsftpd with two configuration
# files.
# Make sure, that one of the listen options is commented !!
listen_ipv6=YES
pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES
0

The solution was that the ftp service was not actually permanently added to the firewall, simply using the following line worked

firewall-cmd --permanent --add-service=ftp

and following that with

firewall-cmd --reload
0

Your vsftpd server listening over IPv6 only and you're trying to connect using IPv4. That's why it's not connecting. Read the configuration file. It's mentioned.

Look the "netstat -tunlep" output. The vsftpd demon is bound to :::21 port only and not to IPv4.

Edit this two line as follows in your configuration

listen=YES
listen_ipv6=NO

Restart your vsftpd server. Hope filezilla will successfully connect. If you want to run vsftpd over both IPv4 and IPv6 run two copy of the daemon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.