2

Using docbook and Apache FOP I can create PDFs that contain cross-references. For example, the Table of Contents of a book looks like this:

 Chapter 1 Introduction........................12

Using the ancient xpdf I can click on the page number 12 and be taken to page 12. Whenever the pointer is on a cross-reference (also for references to figures, tables, sections, etc.) it turns from an arrow into a left-pointing hand to indicate "click me to follow the reference". evince can do the same.

For some reason, okular appears unable to do this. I tried left-middle-right clicks, with and without CTRL, ALT, SHIFT keys. Is this just a configuration snag? Or is okular in fact unable to follow cross-references?

I'm using "Okular 0.20.2 Using KDE Development Platform 4.14.2" on FreeBSD 11.

  • 1
    The short answer is yes, it does, but I don't have any idea why it wouldn't be working for you. There is a "draw border around links" setting (under "Accessibility") that would let you diagnose whether it was the interaction or the detection that was broken. – Michael Homer Jan 4 '15 at 19:12
  • @MichaelHomer I've turned it on and it does indeed draw the borders around the links. What do you do to follow a link? Just left-click? – Jens Jan 4 '15 at 20:22
  • Yes. Right-click gives a one-item menu with a "Follow This Link" entry. – Michael Homer Jan 4 '15 at 20:24
  • @MichaelHomer Hmm. Left-click does nothing. Middle-click enables continuous zooming. Right click brings up a 4-entry menu with the page number as the title and "Add Bookmark", "Fit Width", "Next Bookmark", "Previous Bookmark". – Jens Jan 4 '15 at 20:28
  • @MichaelHomer Solved it: You have to be in "Browse" mode; in "Zoom" mode or "Selection" mode following links is disabled/replaced by a different function. – Jens Jan 4 '15 at 20:41
3

It wasn't a configuration snag, but a user interface snag: following links works while using the "Browse Tool" (Icon: mouse), but not while using the "Zoom Tool" (Icon: Looking glass over paper sheet) or the "Selection Tool" (Icon: pencil in corner of frame).

  • Wow... same here. Seems like a bit of a user interface failure. – Manfred Moser Oct 4 '16 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.