1

I have Linux Mint 17. I wanted to compile python 3.4.2 from source. During the ./configure command, everything went well until an error came out.

configure: creating ./config.status
./config.status: line 476: syntax error near unexpected token `)'
./config.status: line 476: `    *\'*) ac_optarg=`$as_echo "$ac_optarg" | sed "s/'/'\\\\\\\\''/g"` ;;'

This was not the first time I have had this problem. This problem happens when I compile any software from source.
EDIT: I am adding the output of the command cat -n config.status | sed '463,505!d'

case $ac_option in
# Handling of the options.
-recheck | --recheck | --rechec | --reche | --rech | --rec | --re | --r)
ac_cs_recheck=: ;;
--version | --versio | --versi | --vers | --ver | --ve | --v | -V )
$as_echo "$ac_cs_version"; exit ;;
--config | --confi | --conf | --con | --co | --c )
$as_echo "$ac_cs_config"; exit ;;
--debug | --debu | --deb | --de | --d | -d )
debug=: ;;
--file | --fil | --fi | --f )
$ac_shift
case $ac_optarg in
*\'*) ac_optarg=`$as_echo "$ac_optarg" | sed "s/'/'\\\\\\\\''/g"` ;;
'') as_fn_error $? "missing file argument" ;;
esac
as_fn_append CONFIG_FILES " '$ac_optarg'"
ac_need_defaults=false;;
--header | --heade | --head | --hea )
$ac_shift
case $ac_optarg in
*\'*) ac_optarg=`$as_echo "$ac_optarg" | sed "s/'/'\\\\\\\\''/g"` ;;
esac
as_fn_append CONFIG_HEADERS " '$ac_optarg'"
ac_need_defaults=false;;
--he | --h)
# Conflict between --help and --header
as_fn_error $? "ambiguous option: \`$1'
Try \`$0 --help' for more information.";;
--help | --hel | -h )
$as_echo "$ac_cs_usage"; exit ;;
-q | -quiet | --quiet | --quie | --qui | --qu | --q \
| -silent | --silent | --silen | --sile | --sil | --si | --s)
ac_cs_silent=: ;;

# This is an error.
-*) as_fn_error $? "unrecognized option: \`$1'
Try \`$0 --help' for more information." ;;

*) as_fn_append ac_config_targets " $1"
ac_need_defaults=false ;;

esac
  • Do you get the exact same syntax error for any software? or is it different each time? Is /bin/sh a symlink to dash on your system, or to some other shell? – steeldriver Jan 4 '15 at 18:29
  • I get the same error each time. /bin/sh is a symlink to dash. – Vishal Subramanyam Rajesh Jan 5 '15 at 12:11
  • That's strange - the line in question seems to be a perfectly normal part of a standard autoconf case statement. Do you get the same error if you run ./config.status directly? – steeldriver Jan 5 '15 at 13:18
  • Yes steeldriver. I get that error even if I run ./config.status directly. – Vishal Subramanyam Rajesh Jan 5 '15 at 15:03
  • I'm pretty much stumped, the only thing I can suggest is that you edit your post to include some context around the error e.g. the output of cat -n config.status | sed '463,505!d' – steeldriver Jan 5 '15 at 19:06
0

Is there a reason that you don't use the standard Debian Based package manager for Mint? Compiling your own isn't recommended.

This kind of things mostly happens because:

  1. You have some missing dependencies. which would show up as errors, during the './configure' phase.
  2. You may have old compiler, or a compiler that doesn't meet the requirements for the package you are compiling. If that is the case you should update your compiler most likely gcc to recent versions. I urge you to use the Debian based package manager to update gcc if possible.

Also, you should regularly update your system using the Package Manager. In situations where you must compile and install something yourself, issue a ./configure and make as a normal user and only use make install with root privileges, (i.e sudo make install) in the source directory.

  • I don't think I miss any dependency. There are no errors about missing dependency. The error says that the config.status that it generated has an error in it. I have the latest verion of gcc and g++. Python 3.4.2 isn't available in the repositories, only Python 3.4.0 is available. – Vishal Subramanyam Rajesh Jan 5 '15 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.