How can I get a working owncloud server with a working dokuwiki? The dokuwiki entries should not be destroyed...

On a raspberry pi an owncloud installation was made following this article (nginx php5-fpm php5-sqlite php5-gd installed; owncloud.vhost created and linked; owncloud extracted -> /etc/www -> chmod www-data; nginx service started; reboot). However, we did a dokuwiki installation using a howto(german) with these steps:

cd ~
sudo apt-get update
sudo apt-get install apache2 libapache2-mod-php5 
wget http://download.dokuwiki.org/src/dokuwiki/dokuwiki-stable.tgz
tar xfz dokuwiki-stable.tgz
sudo mv dokuwiki-2014-09-29b /var/www
sudo chown -R www-data:www-data /var/www/dokuwiki-2014-09-29b

After that we followed the instructions of


As far as I remember, there were failures in the sudo apt-get install. However, those were at points were services had to be restarted. We did this afterwards by rebooting the raspberry pi.

Now we are able to use our dokuwiki, but not our owncloud. However, before rebooting we were able to access owncloud with https://IP_OF_PI/owncloud. I never got it to sync with other clients so far, but upload of files and access with a browser on other machines was possible.

When we do a (necessary for installation of owncloud)

sudo /etc/init.d/nginx start

the output is

Starting nginx: nginx: [emerg] bind() to failed (98: Address already in use)
nginx: [emerg] bind() to failed (98: Address already in use)
nginx: [emerg] still could not bind()

The output of

raspberry ~ $ apache2ctl -S


/usr/sbin/apache2ctl: 87: ulimit: error setting limit (Operation not permitted)
apache2: Could not reliably determine the server's fully qualified domain name, using for ServerName
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
         default server (/etc/apache2/sites-enabled/000-default:1)
         port 80 namevhost (/etc/apache2/sites-enabled/000-default:1)
Syntax OK

I do not understand what the dokuwiki installation changed so that the nginx is not startable/restartable anymore...

migrated from serverfault.com Jan 3 '15 at 14:40

This question came from our site for system and network administrators.


Ok, I did not understand what nginx (s. Wikipedia) is nor its differences to apache. However, I mixed nginx and apache. These might get in the way of each other. I decided to use apache2. After I have followed this post I can again access owncloud. In short:

  • new certificates in /etc/apache/ssl generated,
  • sudo a2enmod ssl
  • sudo ln -s /etc/apache2/sites-available/default-ssl /etc/apache2/sites-enabled/000-default-ssl
  • In /etc/apache2/sites-enabled/000-default-ssl the respective lines SSLCertificateFile /etc/apache2/ssl/server.crt SSLCertificateKeyFile /etc/apache2/ssl/server.key were changed.
  • sudo /etc/init.d/apache2 restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.