0

I'm trying to update the version of php 5.5 to the latest version (5.5.20 at the time of writing).

I'm doing this on a CentOS v6 machine.

I've tried following the steps here:

https://webtatic.com/packages/php55/

But when I run

yum install php55w

I get a ton of errors like this:

file /usr/lib64/php-zts/modules/ctype.so from install of php55w-common-5.5.20-1.w6.x86_64 conflicts with file from package php-common-5.5.7-1.el6.remi.x86_64

Is there any way I can get round this?

  • Any reason why you are not following the instructions on the page? It nowhere seems to provide that particular yum command (it does indicate yum install php55w php55w-opcache). Did you also skip the rpm prerequisite? – Anthon Jan 3 '15 at 9:14
  • Have you tried removing your earlier php install from the remi repositories? – Ulrich Schwarz Jan 3 '15 at 9:32
  • I don't need the opcache, @Anthon. I didn't skip the rpm step; I also ran rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm. – Tola Odejayi Jan 3 '15 at 10:12
  • @UlrichSchwarz, ow do I remove the php install from the remi repositories? – Tola Odejayi Jan 3 '15 at 10:12
  • @TolaOdejayi: you can inch your way forward by starting with yum remove php-common, then your yum install php55w will conflict for the next packe, and so on. (FWIW, remi [offers 5.5.20]([remi]()), so I don't know why you're not offered that as an update andhave to switch repositories.) – Ulrich Schwarz Jan 3 '15 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.