0

tl;dr : I have one kernel now on fedora and want that ONLY with Windows 8 to show up on my boot menu.


I've been tweaking and geeking with linux kernels. Then I wanted to clean up my boot menu.

So upon googling for remove old kernels, most answers are ubuntu based. This has gotten me confused and lost.

I've tried installing fedora versions apps or tools from what is suggested for ubuntu or tweaking the commands a bit. No luck.

Finally I used this post. I ran sudo yum remove kernel.

Now on my machine this is what I get:

$ rpm -q kernel #<-when I run this..
kernel-3.12.5-302.fc20.x86_64

I then did :

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

However, Now, I have this huge list on my boot menu. Which looks like this:

$ sudo grep "menuentry " /boot/grub2/grub.cfg | cut -c 1-100
menuentry 'Fedora, with Linux fedup' --class fedora --class gnu-linux --class gnu --class os --unres
menuentry 'Fedora, with Linux 3.14.0-rc6-eudyptula-00145-ga4ecdf8-dirty' --class fedora --class gnu-
menuentry 'Fedora, with Linux 3.14.0-rc6-00145-ga4ecdf8' --class fedora --class gnu-linux --class gn
menuentry 'Fedora, with Linux 3.14.0-rc6-00145-ga4ecdf8.old' --class fedora --class gnu-linux --clas
menuentry 'Fedora, with Linux 3.14.0-rc3+' --class fedora --class gnu-linux --class gnu --class os -
menuentry 'Fedora, with Linux 3.14.0-rc3+.old' --class fedora --class gnu-linux --class gnu --class 
menuentry 'Fedora, with Linux 3.12.6' --class fedora --class gnu-linux --class gnu --class os --unre
menuentry 'Fedora, with Linux 3.12.6.old' --class fedora --class gnu-linux --class gnu --class os --
menuentry 'Fedora, with Linux 3.12.5-302.fc20.x86_64' --class fedora --class gnu-linux --class gnu -
menuentry 'Fedora, with Linux 0-rescue-5894da36659c4dcc8799c7b9e06f08e7' --class fedora --class gnu-
menuentry 'Windows 8 (loader) (on /dev/sda1)' --class windows --class os $menuentry_id_option 'ospro

(It was either that or taking a picture of my screen during boot time. I hope it gives a picture of what is on my boot list)

Don't know why it made .old versions and I'm not sure if it's safe to just delete them. I googled and even came up with this post: grub2-mkconfig should ignore .old kernel images so I think grub2 will always rebuild my menu and shove in those .old kernel entries.

I simply want :

to remove the cruft so that I only have Fedora, with Linux 3.12.5-302.fc20.x86_64 (the kernel I'm on now) and Windows 8. Bonus : I want Windows 8 the default.

1 Answer 1

1

The easy way is to install grub-customizer tool:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

When Grub Customizer starts up, you’ll see a list of all the items that show up in the boot menu. To hide entries that you don’t want to see anymore, simply uncheck the checkbox next to them.

But also, you can do it manually, see link.

For Fedora 20:

sudo wget http://download.opensuse.org/repositories/home:/Kenzy:/packages/Fedora_20/home:Kenzy:packages.repo -O /etc/yum.repos.d/home:Kenzy:packages.repo sudo yum update sudo yum install grub-customizer

For Fedora 23+ :

sudo dnf install grub-customizer
3
  • I'm a little sad that even though I whined about constantly seeing ubuntu answers and trying to make them work for fedora, you gave me an ubuntu based answer. Nonetheless I will try this out..... this really makes me also want to just chuck all this and install ubuntu but that'll just take time that I just don't have :(
    – gideon
    Jan 3, 2015 at 8:48
  • There's grub-customizer for Fedora too, I updated my answer
    – kirill-a
    Jan 3, 2015 at 10:35
  • It worked. Thank you so VERY much. I cannot fully express my gratitude, thanks is the best I can do now :)
    – gideon
    Jan 3, 2015 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.