2

so I've been working on setting up a Raspberry Pi running Raspbian lately, and I have almost everything set up the way I want. I plan on using it headless, but I've been using X11 forwarding to view guis when I need to. I have transmission-daemon running, the remote gui accessable from outside my network, and a webserver running that I can access as well.

I got a VPN, and I would like to just send my transmission traffic (not the gui traffic, since you can specify that in settings.json for transmission-daemon) over the VPN. I set my VPN settings in nm-connection-editor to "use this connection only for resources on its network", so I could still browse the web and such using my eth0 interface. When I connect to my vpn, it gives me a ppp0 interface, since its a VPN using ppp0, and when I connect my transmission daemon to that interface, nothing happens. No torrents load. Can someone help?

I figure I need to change the routing tables of my Pi, but I'm not exactly sure what to do.

Here are my routing tables.

Pre-VPN:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         DD-WRT          0.0.0.0         UG    0      0        0 eth0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0

After-VPN (used only for resources on its network):

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
10.4.0.1        *               255.255.255.255 UH    0      0        0 ppp0
37.48.66.67     192.168.1.1     255.255.255.255 UGH   0      0        0 eth0
37.48.66.67     192.168.1.1     255.255.255.255 UGH   0      0        0 eth0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0

After VPN (option disabled):

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         *               0.0.0.0         UG    0      0        0 ppp0
10.4.0.1        *               255.255.255.255 UH    0      0        0 ppp0
37.48.66.67     192.168.1.1     255.255.255.255 UGH   0      0        0 eth0
37.48.66.67     192.168.1.1     255.255.255.255 UGH   0      0        0 eth0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0

If I don't enable the option, all traffic on my Pi goes over the VPN as normal, and transmission works correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.