3

I'm attempting to install Mint 17.1 and have succesfully used Universal USB Installer to create a bootable USB stick. When booting up Mint the pleasing loading screen fails to make an appearance and instead the Grub menu is shown.

How should I proceed to install Linux Mint on this machine?

I have attempted the same proces using YUMI but in this case the machine reverts to the BIOS settings instead of loading Mint / Grub from the USB stick.

To clarify, I'm not intent on dual booting with Windows 8 but replacing the Windows installation with Mint.

  • 1
    Do you already have grub installed in your HD, is that the menu that keeps showing up? Have you booted from a USB successfully before? – Xen2050 Jan 2 '15 at 17:50
  • No, grub is currently not installed on the HD. I have booted from a USB stick before, not on this machine though. – Levon Jan 2 '15 at 17:55
0

If you're planning to dual-boot with windows 8 you should see this question on askubuntu.com with peculiarities about pre-installed windows 8 & UEFI, has pages of instructions & tips.

Could be problems with UEFI if your computer has that, see this Ubuntu help page (Mint's based on Ubuntu, the Ubuntu techniques usually work) for more info: https://help.ubuntu.com/community/UEFI

It may be booting in EFI mode so you see a screen like this: enter image description here

Setting the computer to boot using Legacy mode might work, if your BIOS/UEFI has that setting that you can find. Or use an EFI image, it gets complicated so definitely see the help pages above. Secure boot may only work with the 64-bit versions also, but disabling secure boot &/or EFI should work.

OR the USB may not have been created successfully, you could try using a different too to create it, the Universal USB Installer that I think you tried usually works, but there are others to try too:

If you can install GRUB to your USB I prefer the "copy the whole ISO file" method here: http://www.pendrivelinux.com/boot-multiple-iso-from-usb-via-grub2-using-linux/

  • Thank you for your answer. I've configured the BIOS (UEFI util v2.10) Secure Boot setting to boot "other OS" instead of "Windows EUFI mode" but the net result is the same - the GRUB CLI pop ups when booting. Secure Boot state is enabled and cannot be altered by the user. – Levon Jan 2 '15 at 19:10
  • You're trying the 64-bit version? Apparently 64-bit works best (or only works) with Secure boot - as the first linked dual-boot Q says, regardless of whether or not you actually want to dual-boot most of the steps to run & install are the same – Xen2050 Jan 2 '15 at 19:16
  • Yes, I'm attempting to install the 64bit version of Mint 17.1 – Levon Jan 2 '15 at 19:22
  • I have attempted to install Mint using the instructions provided but the install fails at running Mint from the USB stick, the grub menu shows up instead. – Levon Jan 4 '15 at 8:48
  • Maybe a screenshot of the menu that shows up would help to see what's going on? – Xen2050 Jan 4 '15 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.