0

I just installed Mint 17.1 Cinnamon as a virtual machine using VirtualBox. I want the VM to act as a media server running MediaTomb, however MediaTomb can't access my VirtualBox share.

I know I'm dealing with a permissions issue, but I can't figure out how to resolve it. There are vboxsf and mediatomb groups and the user I'm logged in as belongs to both.

The share is owned by root, and belongs to the group vboxsf with the following permissions: drwxrwx---.

Is there a way to make the MediaTomb application a member of the vboxsf group?

  • 1
    So the share is already mounted, and you can access it with your user? (asking because that's not obvious from your question) If you change the permissions to o+rx on the mountpoint, can you access it in mediatomb? – doktor5000 Dec 31 '14 at 17:25
  • @docktor5000 good point. I can access the share with my user account. I tried setting the permissions to o+rx but the changes don't stick. Is it possible it won't allow me to change the permissions on the mount point while it is mounted? Do I have to unmount it first? – Prdufresne Jan 1 '15 at 18:35
  • "the changes don't" stick means what exactly? The changes don't survive a reboot, or a remount? You need to change the permissions on the mountpoint while it is mounted - the problem here is that virtualbox vboxsf filesystem is not a real filesystem, hence the changes you apply do not stick, they will not even survive unmount and remount. I see only two ways to fix this: Either change the script that mounts that share, or add the chmod call in another script like /etc/rc.d/rc.local which runs on every boot AFTER the virtualbox share has been mounted. I'll dig up something for the former ... – doktor5000 Jan 2 '15 at 1:04
0

Seems you can also fix both abovementioned issues via an entry to /etc/fstab to explicitly mount the shared folder, after disabling automatic mounting via virtualbox.

You need to pay attention to load the vboxsf kernel module early enough, and you should also mark it as "remote" filesystem for systemd, e.g. with the _netdev ( and probably also with nofail if it's not critical for booting your system) option. Via the fstab mount you can also change the permissions/owner/group of the mountpoint.

An example fstab entry could look like this, mounting the shared folder "Mediatomb" to /my/mediatomb/share as user myuser and group mediatomb.

Mediatomb /my/mediatomb/share vboxsf uid=root,gid=mediatomb 0 0

Be sure to set the correct permissions on the regular mountpoint /my/mediatomb/share .

See the following posts for similar solutions:
https://askubuntu.com/questions/365346/virtualbox-shared-folder-mount-from-fstab-fails-works-once-bootup-is-complete
fstab not mounting VirtualBox shared folder?
https://superuser.com/questions/146763/my-virtualbox-fstab-will-not-auto-mount-on-reboot
https://askubuntu.com/questions/252853/how-to-mount-a-virtualbox-shared-folder-at-startup
https://stackoverflow.com/a/22342140/4017010
https://help.ubuntu.com/community/VirtualBox/SharedFolders
https://forums.virtualbox.org/viewtopic.php?t=15868
http://ubuntuforums.org/showthread.php?t=2074022 (using a bind mount)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.