1

I've recently upgraded to OpenSUSE 13.2 and everything seemed to be working fine. The last couple of days I noticed, when I close the laptop it would not hibernate. I tried to go into Gnome Tweak and change the power settings for hibernation, but there is nothing to change there (it's simply blank). Writing pm-hibernate or pm-suspend doesn't do anything.

Does anybody have an idea what might be the cause for this misbehave and a possible solution to this issue? This used to work in 13.1, but doesn't in 13.2 on this specific dell laptop.

Here is my /etc/default/grub file:

# Modified by YaST2. Last modification on Thu Jan  1 20:28:06 EET 2015
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

# If you change this file, run 'grub2-mkconfig -o /boot/grub2/grub.cfg' afterwards to update
# /boot/grub2/grub.cfg.
GRUB_DISTRIBUTOR=openSUSE
GRUB_DEFAULT=saved
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/sda1 splash=silent quiet showopts"
# kernel command line options for failsafe mode
GRUB_CMDLINE_LINUX_RECOVERY="showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe"
GRUB_CMDLINE_LINUX=""
# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM=0x01234567,0xfefefefe,0x89abcdef,0xefefefef
# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=gfxterm
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto
# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true
# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY=true
# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
# Skip 30_os-prober if you experienced very slow in probing them
# WARNING foregin OS menu entries will be lost if set true here
GRUB_DISABLE_OS_PROBER=false
GRUB_THEME=/boot/grub2/themes/openSUSE/theme.txt
GRUB_BACKGROUND=/boot/grub2/themes/openSUSE/background.png
SUSE_BTRFS_SNAPSHOT_BOOTING=true
GRUB_ENABLE_CRYPTODISK=n

I tried running grub2-mkconfig -o /boot/grub2/grub.cfg, mkinitrd and then rebooted, but that doesn't seem to be the solution.

  • Do you have the resume=swap_partition kernel parameter set in /etc/default/grub? – Cthulhu Tentacles Dec 30 '14 at 15:31
  • I've updated my question with more details. The resume partition is pointing to the swap partition. – tftd Jan 2 '15 at 17:59
  • Do you have an external monitor connected to the laptop? If yes, this is normal behaviour. The system assumes that you're using the external monitor and keeps the laptop on. – To Do Jan 31 '15 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.