2

I am using Debian and I'm using Windows as well (much longer).

I loaded a external disk on Windows but when trying to mount on linux again I keep getting the same error:

Error mounting: mount exited with exit code 1: helper failed with:
Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

Tried mounting with command line but got another error:

:~$ sudo mount -t ntfs /dev/sda1 /media
Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.
3
  • What about sudo mount -t ntfs-3g /dev/sda1 /media, or sudo mount -o ro -t ntfs /dev/sda1 /media?
    – muru
    Dec 30, 2014 at 12:25
  • 3
    Has your disk been mounted elsewhere? It may have already been automatically mounted by the system. Look at the output of the mount command on its own or post it here if you are unsure. Also, was Windows shut down cleanly the last time you used it?
    – Graeme
    Dec 30, 2014 at 12:29
  • Please refer to the below link thomas-krenn.com/en/wiki/Hard_Disk_Formatting/… Hope this helps
    – BDRSuite
    Dec 30, 2014 at 14:54

2 Answers 2

1

This is a solution I've pieced together from various sources (namely http://tuxera.com/community/ntfs-3g-faq/#unprivileged) - it's rather long, but it works at least on wheezy and jessie:

  1. open terminal
  2. donwload source:

    $ apt-get source ntfs-3g
    
  3. enter package source directory (name may vary)

    $ cd ntfs-3g-2014.2.15AR.2
    
  4. change package config to use internal fuse:

    $ sed -i -e "s/--with-fuse=external/--with-fuse=internal/" debian/rules
    
  5. build package

    $ sudo apt-get build-dep ntfs-3g
    $ fakeroot debian/rules binary
    

    sometimes building fails, so clean and run again - it should work now:

    $ fakeroot debian/rules clean
    $ fakeroot debian/rules binary
    
  6. install created package (again, name may vary)

    $ sudo dpkg -i ../ntfs-3g_2014.2.15AR.2-1+deb8u2_amd64.deb
    
  7. now you have to configure ntfs-3g as setuid (this IS dangeous and you SHOULD know what you're doing):

     $ sudo dpkg-reconfigure ntfs-3g
    

    and answer yes to setuid, or if it doesn't work, do it manually:

     $ chmod 4755 $(which ntfs-3g)
    
  8. if you do not want to repeat all this after every debian upgrade, set ntfs-3g on hold:

     $ echo "ntfs-3g hold" | sudo dpkg --set-selections
    
-1

I found an answer in this forum, link, which recommends to mount the drive as root:

mount -t ntfs /dev/sdb1 /mnt

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .