3

I'm not too experienced with Linux on personal computers, but I've recently installed Debian Jessie on my laptop (using GNOME 3). It's a Macbook, so there's a command key on the keyboard. Initially, I wanted to swap the control and command keys around, as I was used to some of the hotkeys involving command that OSX uses. So I edited /etc/default/keyboard and added the option altwin:ctrl_win (or possibly in some other place, but I do not quite recall - that's the annoying part).

However, I soon found out that this did not swap the keys, but instead remapped command to be an extra control key. At this point I'd very much like to undo the swap and just use the keys in their original function. However, I cannot seem to get it back the way it used to be.

I edited /etc/default/keyboard to take out the option, but when I call setxkbmap -query, it still shows up with altwin:ctrl_win. Do I need to do something to make it re-read the configuration file? Or am I in the wrong file entirely? I tried dpkg-reconfigure keyboard-configuration, without success. I tried grepping through the entire system, but I could find no file that causes this configuration.

When I call setxkbmap -options to clear the options, it does restore the old functionality, but this is non-persistent, so I need to do this on every boot. Sure, I could add it to rc.local or .xinitrc or .bashrc, but I'd rather treat the cause instead of the symptom (and learn why it happens).

What am I missing here?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.