11

On a Lenovo Laptop with Ubuntu 14.04 I am not able to display the current screen's stuff on a Monitor connected with HDMI. The HDMI cables are both plugged in to the laptop and the monitor, and the monitor is switched on.

Going to

Systems Settings -> Displays

and clicking on 'Detect Displays' only the standard laptop screen is shown. The external monitor is not shown.

How can I fix this problem in order to see the current screen on both, the laptop screen and on the monitor screen?

Also, it is unimportant if the screen can play the laptop's sound. I only want the visible screen output shown on the external monitor as well, which works fine when starting the laptop with the Windows OS (without any change to hardware and/or cables)...

Additional information:

  • xrandr only shows the standard monitor; the full output of xrandr is

    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 1600 x 900, current 1600 x 900, maximum 1600 x 900
    default connected primary 1600x900+0+0 0mm x 0mm
       1600x900       77.0* 
    
  • The HDMI connection works flawless when running the laptop with Windows (dual-boot)

  • Output of line of lspci:

    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Lenovo Device 3977
    Flags: bus master, fast devsel, latency 0, IRQ 7
    Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at b0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 3000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    
  • Output of sudo lshw -C display:

    *-display UNCLAIMED     
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:3000(size=64)
    
  • I also tried to remove and re-install the package xserver-xorg-video-intel - but it did not change anything (after reboot).

  • I followed the steps given here for a Samsung LS22B150NS monitor with a resolution of 1920 x 1080 pixels. But I got an error xrandr: cannot find output "VGA1":

    alex:~$ cvt 1920 1080
    # 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
    Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    alex:~$ xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    xrandr: Failed to get size of gamma for output default
    alex:~$ xrandr --addmode VGA1  1920x1080_60.00
    xrandr: Failed to get size of gamma for output default
    xrandr: cannot find output "VGA1"
    
  • Can you post the output of lshw -C display to verify there is only 1 Graphics card? – eyoung100 Dec 29 '14 at 15:53
  • Added to question – Alex Dec 29 '14 at 15:57
  • So, there is still no solution for this? I have practically the same problem with the same output from xrandr. – Santi Feb 19 '16 at 6:16
  • I had a similar issue and fixed it by rebooting with the HDMI cable plugged in. If I had to guess it's something to do with power management. – Ammar Bandukwala Apr 28 '17 at 21:59
1

Try to install the latest intel hd graphics driver from here: Intel graphics Installer for linux 1.2.1

1

My second HDMI monitor was working before, but for whatever reason I managed to break it.
Both display settings and xrandr did not show that HDMI was connected. (The monitor itself did not say cable disconnected when plugged in).

What worked for me, was removing the display configuration file ~/.config/monitors.xml and rebooting.

So to be clear, my issue was a simple configuration issue.

  • With mine I had to plug in another monitor into my laptop and then the original. Plugging in the new laptop somehow reset something in Elementary OS – Sevenearths Sep 4 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.