2

I am unable to install Skype on Debian Jessie (64 bit). I have already enables i386 architecture . The issue is with the installation of the package libqtwebkit4:i386:

rsiwal@rsiwal-jessie:~$ sudo gdebi Downloads/skype-debian_4.3.0.37-1_i386.deb 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done 
Building data structures... Done 
This package is uninstallable
Cannot install 'libqtwebkit4:i386'
rsiwal@rsiwal-jessie:~$ sudo apt-get install libqtwebkit4:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpam-systemd : Depends: systemd (= 215-8) but 208-8 is to be installed
 udev : Breaks: systemd (< 215-1) but 208-8 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
  • Can you post the results of apt-cache policy libqtwebkit4 libpam-systemd systemd in the question? I have the same version of skype installed on Debian Wheezy and it works for me. – Faheem Mitha Dec 29 '14 at 8:28
2

Skype is not supported in Debian. This is why it is not contained in any of the repos (you were wondering, weren't you?).

The Debian Wiki page about Skype strongly encourages you to use one of the FOSS alternatives, like ekiga.

The same page, however, also contains some info on how to install skype on Debian systems. It even contains the following lines about your specific problem.

Question: Why can I not install libqtwebkit4:i386?

Answer: If apt-get is not able to install libqtwebkit4:i386 as dependency, try installing with aptitude, if you know what are you doing.

You probably need the version skype-debian_2.2.0.35-1_amd64.deb, as newer versions have problems associated with PulseAudio. One can edit the deb package to fix the dependencies for Wheezy. The control file should have:

Depends: libstdc++6 (>= 4.1.1-21), libasound2 (>> 1.0.14), libc6 (>= 2.13-1), libgcc1 (>= 1:4.1.1-21)

If I were in your shoes, I would try ekiga. And, BTW, it's Debian Jessie.

  • that's really sad - I was never able to accomplish a single thing with Ekiga. I thought we were open to things that work. Is there a tutorial for Ekiga? BTW, never needed a tutorial for Skype. – Thorsten Staerk Dec 29 '14 at 10:11
  • @ThorstenStaerk The installation is trivial, aptitude install ekiga. Then get yourself a SIP code, in my case sip:MariusMatutiae@ekiga.net, and you are basically done. – MariusMatutiae Dec 29 '14 at 10:38
  • It has been working fine on Debian Wheezy 7.x. – Rajnesh Siwal Dec 29 '14 at 11:20
  • 1
    The following command worked and the skype is now working fine: aptitude install libqtwebkit4:i386 – Rajnesh Siwal Dec 29 '14 at 15:24
  • 1
    Eikiga is good, but no use when needing to communicate with others using Skype. Sometimes it's necessary to be where everyone else is, rather than sitting alone in a different corner. – roaima May 23 '15 at 20:08
1

Use the dynamic version from skype.com. The debian version skype provides isn't compatible any more.

  • 2
    Hi and welcome to the site. There might be an answer here, could you i) explain how to install the dynamic version and ii) provide a link to it? As it stands, your answer is more of a comment. – terdon May 23 '15 at 17:22
  • @terdon this method worked for me. Download the skype-4.3.0.x.tar.bz2 file using the dropdown option "dynamic" from skype.com/en/download-skype/skype-for-computer – Ivar Persson Mar 16 '16 at 19:21
1

I had all sort of issues with this and did get the 32-bit version of Skype working for a while, but then had more issues when I tried to install some multimedia software... so in the end I did this:

(FYI, I am running Debian Jessie (64bit), and Gnome 3.)

I downloaded skype-4.3.0.37.tar.bz2 ("Dynamic" in dropdown menu) from here: http://www.skype.com/en/download-skype/skype-for-computer/

Then I unpacked the file and did the following:

  • Copy the *skype binary to /usr/bin/
  • Copy the skype.desktop file to /usr/share/applications/
  • Copy the icons to /usr/share/pixmaps/ (and rename one to skype.png)
  • Copy (or move) the remaining files to /usr/share/skype (create the skype folder if needed)

And that's it... Skype should now be available from the menu.

Worked for me.

  • What package did you add to get: libQtDBus.so.4 – mcr Jan 20 '16 at 23:07
  • This method worked for me as well on Debian Jessie. Just a small correction, the paths are /usr/* and not /user/* on debian. – Ivar Persson Mar 16 '16 at 19:25
  • @IvarPersson: Fixed :-). – pevik Sep 26 '16 at 9:41
0

Its because of some library dependency, and whenever you face this issue you will need to use the same command and it will be surely solved. Same will be happen with the TeamViewer. In short whenever the dependency issue occur with sudo dpkg -i package.deb

Just use below command to install all the dependencies forcefully :::)))

sudo apt-get -f install

0

Use below commands to make it, I have just installed the skype in my system.

first download skype from below link: http://download.skype.com/linux/skype-debian_4.3.0.37-1_i386.deb

Then add i386 architecture on your system using below command and update the packages as well:

sudo dpkg --add-architecture i386

sudo apt-get update

Then go to download directory and use these commands:

sudo dpkg -i skype-debian_4.3.0.37-1_i386.deb

sudo apt-get -f install

  • Does not work with jessie. – mcr Jan 20 '16 at 23:05
-3

You are using i386, that's 32 bit. You have to use 64 bit.

Run: apt-get install -f or dpkg --reconfigure

  • It did not help as the installation of libqtwebkit4:i386 fails – Rajnesh Siwal Dec 29 '14 at 11:17
  • Skype is 32bit so the dependencies have to be 32bit too – roaima May 23 '15 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.