0

I have a Dell Latitude D830 with a built in wifi adapter. I currently have a dual boot of Kali and Linux Mint. In Kali, I'm able to see and connect to wifi. In Mint I'm able to see and attempt to connect, however it always says the PW is wrong.

I know the PW isn't wrong. I've reset the router countless times. On the same machine I can connect if I boot on Kali. Only difference I've been able to see is when I run ip link show wlan0 on Mint I get:

$ ip link show wlan0
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
    link/ether 00:1b:77:01:66:cb brd ff:ff:ff:ff:ff:ff

and on Kali I get the same output except where it reads "state DOWN" it reads "state UP"

I've tried to manually ifconfig wlan0 up and it seems to work but still lists the state as down no matter what I do.

Any suggestions!?

  • What is the output of cat /etc/network/interfaces on Mint? – cremefraiche Dec 28 '14 at 7:20
  • $ cat /etc/network/interfaces auto lo iface lo inet loopback – Matty C Dec 28 '14 at 7:26
  • Well that is how it should be. What happens when you run sudo ifdown wlan0 then sudo ifup wlan0? Specifically, what is the output of the second command? – cremefraiche Dec 28 '14 at 7:29
  • [code]ifdown: interface wlan0 not configured[/code] – Matty C Dec 28 '14 at 7:33
  • That is the first command, I would need to know the output of sudo ifup wlan0 once you run it after you have run the first command. – cremefraiche Dec 28 '14 at 7:34
0

Try running the following command in Mint:

sudo nano /etc/network/interfaces

Edit it to appear as the following:

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp

Once it looks like that, press Ctrl-X, then y when asked if you want to save, then [enter] when asked what you want to save the file as.

Finally, run sudo reboot, and see if your problem persists.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.