6

x11vnc is running on the server, and

vncviewer FullScreen=1 ViewOnly=1 UseLocalCursor=0 DotWhenNoCursor=1 computer0:5900

is being used to view the server's display on the client's display. The client's vncviewer is being provided by TigerVNC 1.3.1. The client shows everything that is on the server's display except the mouse cursor. I'm not sure whether to look for a setting to change on the client or the server, so I've been looking at both.

In the x11vnc manual page I found the -cursor option which I tried setting to arrow, but that didn't appear to have an effect. For vncviewer I found the UseLocalCursor and DotWhenNoCursor options. I'm not sure whether either of them are relevant, but they don't seem to have had an effect either.

How can I make cursor movements on the server visible on the client? I don't much care about the appearance of the cursor on the client as long as it's visible.

2

I have had no luck with getting a cursor to show up in the vncviewer provided by TigerVNC 1.3.1, but the vncviewer from TightVNC 1.3.10 does show a cursor. Running

x11vnc -cursor none -display :0

on the server and

vncviewer -viewonly -fullscreen -x11cursor computer0:5900

on the client results in the position of the client's cursor being updated to reflect that of the server, which seems pretty optimal to me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.