1

I have acer laptop with pre-installed windows 8.1 so comes with efi firmware. I dual boot Linux Mint after changing efi to legacy and set bootloader installation of Linux to efi partition. Then I enable efi but it loads windows only and cannot find Linux Mint option anywhere.

closed as unclear what you're asking by Gilles, Anthon, jasonwryan, slm Dec 27 '14 at 21:30

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • @HalosGhost I did not installed mint under MBR but under efi. But during installation its partition type was showing fat32 – maharjanaman Dec 27 '14 at 5:39
  • I'm confused. Why do you think the type of filesystem is the important factor here? – HalosGhost Dec 27 '14 at 5:41
  • @HalosGhost Now i'm confused...here my problem..when efi firmware is enabled linuxmint doesnot boot and when disabled windows wont boot. So i tried installing mint boot loader in efi, based on other forums posts and followed there steps completely but cant find option to boot linuxmint – maharjanaman Dec 27 '14 at 5:55
  • Please edit your question and explain exactly what you have done. What are the steps you followed? How did you install the bootloader? On which partition? We need more information to be able to help you. – terdon Dec 27 '14 at 12:21
1

You should install Linux in EFI too if you want using it with EFI.

Simplest would be reinstall Linux in EFI mode (do not format EFI partition while installation). But you don't have to do it. You can just mount your EFI partition to '/boot/efi', add new line to fstab and install grub-efi.

So you must do something like this: lsblk to find EFI partition. For me it is '/dev/sdb1' (it will be first partition on your primary disk). Then mount it sudo mount /dev/sdb1 /boot/efi. Add line like this: /dev/sdb1 /boot/efi vfat umask=0077,shortname=winnt 0 0 to '/etc/fstab' for automatic mounting after boot. Then install/reinstall grub-efi. Last step is in your computer firmware. You will have to most probably add new boot option.

This is not tested on Linux Mint. I did this multiple times but only on Fedora, but it should be same.

Edit: I read again question and comments. Your problem could be so simple as no boot entry in pc firmware (so just go to firmware and add new one if you see Linux Mint) or complicated as wrong installation. So check if your installation medium is booted in efi mode. Also check if you installing on disk with efi partition and if efi partition is part of installation (is selected as target with mount option /boot/efi/). Also you can check from Linux folders in /boot/efi/EFI: sudo ls /boot/efi/EFI. There should be BOOT, Microsoft and folder for LinuxMint.

0

As folks have told already, you're basically better off reinstalling in EFI mode (EFI bootloaders can only be installed when booted that way, sort of chicken-and-egg at times). There's fine manual over here, generally recommended.

Not the answer you're looking for? Browse other questions tagged or ask your own question.