1

I recently installed Kali Linux, switching from Scientific Linux. The only problem is my wireless driver, which doesn't want to install at all.

lspci -nn | grep Net :

02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57785` Gigabit Ethernet PCIe [14e4:16b5] (rev 10)
03:00.0 Network controller [0280]: Broadcom Corporation BCM43227 802.11b/g/n [14e4:4358]

ifconfig -a :

eth0      Link encap:Ethernet  HWaddr dc:0e:a1:1e:75:35  
      inet addr:192.168.0.108  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::de0e:a1ff:fe1e:7535/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:23812 errors:0 dropped:0 overruns:0 frame:0
      TX packets:13319 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:30858992 (29.4 MiB)  TX bytes:1221973 (1.1 MiB)
      Interrupt:16 

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:28 errors:0 dropped:0 overruns:0 frame:0
      TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:1680 (1.6 KiB)  TX bytes:1680 (1.6 KiB)

iwconfig :

eth0      no wireless extensions.

lo        no wireless extensions.

uname -r :

3.14-kali1-amd64

So far, I have tried downloading the driver from official site, and tried to build the module on my own, but when using "make" it would take forever and freeze. I am not too experienced using Linux, but I don't think it should do like that. Then I have tried following these steps (using module-assisstant) http://community.linuxmint.com/tutorial/view/218. When it gets to build the module it reaches around step 300 and then says it failed, without any error. Then I tried to use the broadcom-sta-dkms. apt-get install broadcom-sta-dkms

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  broadcom-sta-source
The following NEW packages will be installed:
  broadcom-sta-dkms
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B/2,208 kB of archives.
After this operation, 4,164 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 338796 files and directories currently installed.)
Removing broadcom-sta-source ...
Selecting previously unselected package broadcom-sta-dkms.
(Reading database ... 338788 files and directories currently installed.)
Unpacking broadcom-sta-dkms (from .../broadcom-sta-dkms_5.100.82.112-8_all.deb) ...
Setting up broadcom-sta-dkms (5.100.82.112-8) ...
Loading new broadcom-sta-5.100.82.112 DKMS files...
Building only for 3.14-kali1-amd64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.

But that's weird, because I have both the kernel source and the headers installed. I would appreciate your help very much.

  • Same exact problem, but with Kali 4.3.0 and broadcom-sta-dkms 6.30.223.271. – C. Ross Jul 31 '16 at 1:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.