1

I tried doing the following to add a new category named "Electronics" in Whisker Menu on Linux Mint 17.1 with Xfce 4.10.1:

  1. I added this text to ~/.config/menus/xfce-applications.menu just after rest of entries for categories
    <Menu>
        <Name>Electronics</Name>
        <Directory>xfce-electronics.directory</Directory>
        <Layout>
            <Merge type="menus" />
            <Filename>geda-gattrib.desktop</Filename>
            <Merge type="files" />
        </Layout>
    </Menu>

and

<Menuname>Electronics</Menuname>

down in the file (with other similar entries).

  1. Then, I added <Menuname>Electronics</Menuname> to ~/.config/menus/applications.menu along with similar entries.

  2. Last, I made a new file named ~/.local/share/desktop-directories/xfce-electronics.directory and added wrote the following to it:

    [Desktop Entry]
    Type=Directory
    Icon=file-manager
    Name=Electronics
    Comment=

However, I am not seeing a new category in either Whisker Menu or Alacarte or Menulibre (menu editors). Is there something else to be done that I missed?

5
  • Have you did: Start -> Properties -> Choose the custom menu option and navigate and select the custom menu file ~/.config/menus/xfce-applications.menu? – kirill-a Dec 25 '14 at 7:50
  • I tried but I can't find the option- previously, if memory serves, it could be accessed under the title Menu File after right clicking on the WhiskerMenu "icon" and selecting Properties . Now, in version 1.4.1, it seems that they have removed it from there. Is there anywhere else I can find it? – strNOcat Dec 25 '14 at 9:08
  • If you're using 4.10 or 4.12, then you can edit the Menu using alacarte or menulibre utilities. The option is here: link – kirill-a Dec 25 '14 at 9:37
  • Application Menu! I was looking in the Whisker Menu's options. – strNOcat Dec 25 '14 at 10:01
  • So, have you resolved your issue? – kirill-a Dec 25 '14 at 10:18
0

I made it the same way as you but also added a include tag in ~/.config/menus/xfce-applications.menu:

<Menu>
    <Name>Electronics</Name>
    <Directory>xfce-electronics.directory</Directory>
    <Layout>
        <Merge type="menus" />
        <Merge type="files" />
    </Layout>
    <Include>
        <Category>Electronics</Category>
    </Include>
</Menu>

Of course I also added the ~/.local/share/desktop-directories/xfce-electronics.directory file like you. You can then add desktop files under ~/.local/share/applications with the category "Electronics".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.