1

While trying to install CentOS 6.4 IN DUAL BOOT with win 7 there was this error "sda must have gpt label". I don't know how to fix it and I also don't want to repartition my hard drive.

1

Disable UEFI in BIOS (manual) or create a GPT partiition table (gparted or gdisk).

Example of creating one from Arch wiki:

# gdisk /dev/sdX o # create new empty GUID partition table n # partition 1 [enter], from beginning [enter], to 100GiB [+100GiB], linux fs type [enter] n # partition 2 [enter], from beginning [enter], to 108GiB [+8GiB], linux swap [8200] w # write table to disk and exit

Another option is to use parted utility during installation. Inject "CTRL+ALT+F2" during your installation process to go on command line with 'parted' utility.

parted
(parted) print /dev/sda
(parted) select /dev/sda
(parted) mklabel gpt
(parted) yes
(parted) print /dev/sda
(parted) quit

then return to installation process with CTRL+ALT+F1.

  • My pc is 3 years old.there is no options for UEFI in BIOS setup. – sandy Jan 3 '15 at 20:38
  • You'll have to reinstall system and add a gpt label to partition. This will remove all data on partition. I added steps to do during installation to answer. – kirill-a Jan 3 '15 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.