I am using Raspbian with a static setup in /etc/network/interfaces. I have read from multiple credible sources that the /etc/resolv.conf file is populated by other software on the system, commonly DHCP.

To test this, in my /etc/dhcp/dhclient.conf I tried adding the following

prepend domain-name-servers 127.0.0.1 2.2.2.2;

I then rebooted my system, expecting to find these addresses as nameservers in my /etc/resolv.conf, however this was not the case, both addresses do not exist, and my resolv.conf file is untouched.

I also tried changing the prepend parameter to the following

supersede domain-name-servers 127.0.0.1 2.2.2.2;

After reboot, this also did nothing.

I also tried editing /etc/network/interfaces and added the following

dns-nameservers 55.55.55.55

Again, after reboot, no changes.

Is this intentional behavior? Why isn't resolv.conf being updated/overwritten?

  • What is your DHCP client/server configuration? Complete files please. – Braiam Dec 23 '14 at 0:49
  • And the content of /etc/resolv.conf too. – Braiam Dec 23 '14 at 1:03
  • What do you mean by "static setup"? Sounds like you're not using DHCP at all. – Hauke Laging Dec 23 '14 at 1:25
  • @HaukeLaging I used parameters in both dhcpconfig file and /etc/network/interfaces, /etc/resolv.conf remains untouched. – UnixUnix Dec 23 '14 at 1:36
  • does your distribution have the package resolvconf installed? (check with dpkg -l | grep resolvconf). This guy is the responsible to handle nameservers as parameters of /etc/network/interfaces. More information: wiki.debian.org/NetworkConfiguration#The_resolvconf_program – nwildner Dec 23 '14 at 15:33

This seems to be a bug, which I've reported in the Debian BTS a few hours ago: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773749

Look at /run/resolvconf/resolv.conf if something has changed.

  • I tried nano /run/resolvconf/resolv.conf, returns a new file as the file doesnt exist. I read parts of your bug report, which file did you find was being updated on your end? (it sounded like in the report it was done elsewhere) – UnixUnix Dec 23 '14 at 0:34
  • How you know OP is using WiCD? – Braiam Dec 23 '14 at 0:49
  • @Braiam wicd does nothing concerning /etc/resolved.conf; it just uses dhclient, which has the responsibility of updating /etc/resolved.conf, and the OP uses dhclient too. I mentioned wicd in my bug report just for the context, but my bug report is against the isc-dhcp-client package, which provides dhclient. – vinc17 Dec 23 '14 at 1:02
  • Actually, you can't be sure who generates the /etc/resolv.conf file (if it's generated at all). That's my point actually. – Braiam Dec 23 '14 at 1:05
  • 1
    @Braiam /etc/resolved.conf should be generated by dhclient or something called by dhclient, since this is the file where the nameservers are taken from. – vinc17 Dec 23 '14 at 1:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.