I used to use gconftool-2 to edit keys in this way (here I change the cursor shape in gnome-terminal):

gconftool --type string --set /apps/gnome-terminal/profiles/Profile0/cursor_shape ibeam

But it doesn't work anymore, and I feel like there is a problem with the DBus daemon, even though I can't explain why.

This command does change the key in the ~/.gconf/.../Profile0/%gconf.xml, where I can now read:

<entry name="cursor_shape" mtime="1419267709" type="string">

But it has no effect on my cursor shape anymore: it is still a block.

Now, here is an interesting fact: if I use gconf-editor and navigate to this key, I find it set to block.

enter image description here

And if I now edit this key with the gui, it does change my cursor shape.

Everything behaves like the keys stored in memory and the keys stored in the .xml files are not updated together with the gconftool-2 command.

I also noticed that gconftool-2 --ping doesn't return anything.

I have tried reinstalling gconf2 gconf2-common gconf-service gconf-default-service with no success. I also tried erasing the whole ~/.gconf folder, but the same thing keeps happening.

I have had a look at gsettings but my gnome-terminal doesn't seem to be supported with it since the schema org.gnome.terminal doesn't exist and since I can't find any folder gnome-terminal nor gnome/terminal under dconf-editor.

This is driving me mad, did it happen to anyone? How is the gconftool-2 supposed to refresh and get instant changes in the running apps?

1 Answer 1


Got it! Credits to this answer. I added the following lines to my .zshrc or .bashrc:

sessionfile=`find "${HOME}/.dbus/session-bus/" -type f`
export `grep "DBUS_SESSION_BUS_ADDRESS" "${sessionfile}" | sed '/^#/d'`

And the settings are now refreshed as soon as I use gconftool-2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .