1

I'm trying to install Heroes of Newerth on openSUSE 13.2, KDE 4.14. I downloaded the client from official website.

I checked is executable option in properties. But when i double clicked on the file nothing happened. Then I opened terminal:

When I type sh ./HoNClient-3.6.0.sh the output is:

199096+0 records in
388+1 records out
199096 bytes (199 kB) copied, 0.1094 s, 1.8 MB/s
./HoNClient-3.6.0.sh: line 17: ././HoNClient-3.6.0.sh-bin: cannot execute binary file

I tried ./HoNClient-3.6.0.sh but the output is same.

I give a shot to chmod +x ./HoNClient-3.6.0.sh but it didn't solve the problem.

Then checked file with file HoNClient-3.6.0.sh.

HoNClient-3.6.0.sh: POSIX shell script executable (binary data)

I investigated the problem and saw 32-bit / 64-bit conflict.

Tried uname -a

Output:

Linux linux-whh5.site 3.16.6-2-desktop #1 SMP PREEMPT Mon Oct 20 13:47:22 UTC 2014 (feb42ea) x86_64 x86_64 x86_64 GNU/Linux

The output of ldd filename:

ldd HoNClient-3.6.0.sh
 not a dynamic executable

I can't figure out what causes the problem. Is there anyone knows the problem's cause and its solution?

  • 1
    The first line of output looks like the output of dd ( a data copying program ), it must have been called in the shell script, the second line is about a different file it ends -bin this is the file that can not be executed. It must have been created by the shell script, then the script tried to run it, but because of a bug in the script, it is not executable (or wrong executable type, try ldd of this file). – ctrl-alt-delor Dec 21 '14 at 15:33
  • @richard Thanks, your comment didn't solve the problem but expanded my perception about it. I tried ldd of HoNClient-3.6.0.sh-bin but encountered No such file or directory – egegunes Dec 21 '14 at 15:46
  • Where did you downloaded this? – Braiam Dec 21 '14 at 16:06
  • Last night I installed dota2 but it was a graphic problem. I thought graphic card driver caused that. I installed nvidia driver and boom, openSUSE crashed irreversibly. That's why :) file HoNClient-3.6.0.sh-bin says cannot open 'HoNClient-3.6.0.sh-bin' (No such file or directory) – egegunes Dec 21 '14 at 17:25
  • The shell script is extracting the -bin file, and cleaning it up when it detects an error. We really need to see what's in that file to help you. Can the file be downloaded by anyone? If not, post the beginning of HoNClient-3.6.0.sh — everything that looks like a shell script, plus the first few lines/kilobytes of binary data at the end. Do you have a 32-bit or 64-bit system? If 64-bit, do you have 32-bit libraries installed (I don't know how that's done on SuSE)? – Gilles Dec 21 '14 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.