1

I am in the midst of setting up a new Debian workstation. Using one AMD HD 7870, I am running 3 screens. It took a little doing to get to the point where all three screens were showing up correctly, the first step being to install the fglrx driver (as outlined here).

Currently, my displays are arranged how I want them, and I only have two issues I'm trying to deal with.

1) I can't seem to change the primary display. I saw a forum post about adding a 'Primary' flag to the Monitor section in xorg.conf, but this didn't seem to work. I can live with this, but I'd love to find a way to fix it.

2) My bigger problem - my mouse seems to be confused about what screen it's on. If I so much as click the menubar on a window, it instantly goes all the way to the right of my right-most screen. The only way I can get it placed where I want is to Alt+click and drag it. Regular click and drag means pulling it over from the right side every time, since as soon as I click on it to move it, it immediately jumps to the right.

Other related weirdness - I tried to drag and drop a file in the file manager, and it didn't go anywhere ...until I opened a second window on a different screen. The file I was dragging and dropping showed up on the other screen and dropped where I put it in the second window - despite the mouse still being on the first screen.

These problems all go away when I disable Xinerama. The trouble is, when I disable Xinerama, 2 out of my 3 screens show up all white, and of course, I can't drag any applications over to them, making them more or less useless.

I'd really love any ideas anyone has on this. Below is my xorg.conf file. Let me know if there's anything else you need. Thanks in advance.

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
    Screen         "aticonfig-Screen[0]-1" LeftOf "aticonfig-Screen[0]-2"
    Screen         "aticonfig-Screen[0]-2" LeftOf "aticonfig-Screen[0]-0"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
    Option      "Xinerama" "on"
EndSection

Section "Extensions"
    Option      "Composite" "Enable"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-1"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-2"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
    Screen      0
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-1"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
    Screen      1
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-2"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
    Screen      2
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
                Modes "1920x1080_60.00"
    EndSubSection
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-1"
    Device     "aticonfig-Device[0]-1"
    Monitor    "aticonfig-Monitor[0]-1"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
                Modes "1920x1080_60.00"
    EndSubSection
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-2"
    Device     "aticonfig-Device[0]-2"
    Monitor    "aticonfig-Monitor[0]-2"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
                Modes "1920x1080_60.00"
    EndSubSection
EndSection
0

Section "Extensions" Option "Composite" "Enable" EndSection

That is your problem --> XINERAMA does not work with 3d effects Remove the compiz effects and xinerama will work out-of-the-box really well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.