4

tmux ignores the configuration files: both /etc/tmux.conf and ~/.tmux.conf. Even I pass the path to the configuration file, using tmux -f path/to/tmux.conf it still doesn't load it.

The configuration file contains:

set -g default-terminal "screen-256color"
set -g status-bg "#105C8D"
set -g status-fg white

set-window-option -g xterm-keys on

set -sg escape-time 0

I see that the status bar background is lightblue even the configuration sets it to dark blue (#105C8D). Also, 256 colors are not supported. That's why I guess the file is not loaded.

How can I fix the issue?

Running tmux version 1.9a but had the same issue with 1.8, on Ubuntu 14.04.

I already saw:

I don't get any errors regarding the config syntax.

3
  • What happens if you create a new tmux.conf file with the single line set -g status-bg "#105C8D" and run tmux -f tmux.conf ?
    – janos
    Dec 20, 2014 at 20:20
  • @janos I did the troubleshooting together with Cristian and we already tried this. The color is not changed... Dec 20, 2014 at 20:28
  • I have already tried to create a new tmux.conf and run tmux -f tmux.conf, but nothing has changed.
    – Cristian
    Dec 21, 2014 at 7:59

1 Answer 1

3

Found a solution... which is probably not the best, but its working.
Open tmux with: tmux -2 which force tmux to assume the terminal supports 256 colours.

2
  • Is this in gnome-terminal?
    – jasonwryan
    Dec 26, 2014 at 19:43
  • yes it is a gnome-terminal.
    – Cristian
    Dec 28, 2014 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.