2

Running CentOS 5.5 with Puppet 0.25.5

I have installed and am using the puppet-sysctl module.

However the following error occurs:

//linux_tuning/Sysctl::Value[net.core.rmem_default] Sysctl[net.core.rmem_default] (err): Failed to retrieve current state of resource: No ability to determine if sysctl exists
//linux_tuning/Sysctl::Value[net.core.rmem_default]/Exec[exec_sysctl_net.core.rmem_default] (notice): Dependency sysctl[net.core.rmem_default] has 1 failures
//linux_tuning/Sysctl::Value[net.core.rmem_default]/Exec[exec_sysctl_net.core.rmem_default] (warning): Skipping because of failed dependencies

sysctl is installed. And /etc/sysctl.conf is present.

Anyone have an idea as to why this is happening and have an idea as to how to fix it?

An excerpt from puppet.conf:

[main]
    vardir = /var/lib/puppet
    logdir = /var/log/puppet
    rundir = /var/run/puppet
    ssldir = $vardir/ssl
    runinterval = 21600
  • Can you post your puppet.conf? – Kowh Jul 30 '11 at 1:08
  • @Kowh Any part in particular or just the whole thing? – Swiss Jul 30 '11 at 1:25
  • The [main] section in particular. – Kowh Jul 30 '11 at 2:12
2

Looks like you need to enable pluginsync:

In puppet.conf:

[main]
pluginsync = true
  • This is set under [puppetd], should it be under [main] as well? – Swiss Aug 1 '11 at 18:03
  • Might as well move it. Putting it under [main] causes it to apply to all puppet executables, making the other entry redundant. – Kowh Aug 1 '11 at 23:11
  • This module is poorly documented. I've been trying to figure out how to integrate it into my install. – ewwhite Feb 20 '12 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.