5

I have Fedora 21 installed. Last time it booted, I changed Gnome theme. Then I restarted and now I get following:

photo

If I select to continue boot, computer restarts and I get this window again. If I select to enroll something, I can travel through some folders on my disk.

Any ideas how I can repair my Fedora installation?

Possibly, I have deleted some important packages.

  • "I changed gnome theme" -> It wasn't one of the BSOD themes, was it? ;) P.S. "MOK" = Machine Owner Key. – goldilocks Dec 18 '14 at 21:26
  • @goldilocks, nope. I don't know if theme change can be anyhow related to this problem. – Savenkov Alexey Dec 18 '14 at 21:34
  • Boot into your BIOS (sorry, UEFI) configuration and see if you have "secure boot" enabled. If so, try disabling it. That screen probably isn't the OS, and it may not even be the bootloader. Is this an Acer, by any chance? – goldilocks Dec 18 '14 at 21:59
  • @goldilocks, I have HP Probook 470 G0. Secure Boot is disabled. I have just installed Windows as second OS, but this MOK Management still shows up. I am able to run Windows from HP Menu by selecting EFI manually, but not Fedora. This problem looks like not to be related directly with unix. I guess GRUB boot loader had been corrupted(before installation of Windows). Now I'll try to run Fedora from Live CD and restore GRUB. I'll report my progress here. Thanks for your replies! – Savenkov Alexey Dec 19 '14 at 18:26
  • @goldilocks, I had no luck. Have no other ideas how to remove this MOK Management on boot. Gonna make factory reset. – Savenkov Alexey Dec 20 '14 at 9:57
2

I ran into this issue today but was able to fix it and save my install by following these steps:

  • Download a live CD and boot on the affected machine.
  • Open terminal
  • fdisk -l and cat /etc/fstab to see what devices are mounted where
  • mount the correct devices to the corrects parts of /mnt
  • mount --bind /dev /mnt/dev
  • mount --bind /proc /mnt/proc
  • mount --bind /sys /mnt/sys
  • mount -o bind /run /mnt/run
  • chroot /mnt
  • Reinstall the signed shim into /boot/efi: dnf reinstall grub2-efi-x64 grub2-efi-x64-modules shim
  • chmod -x /etc/grub.d/30_os-prober
  • grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
  • exit
  • reboot
  • You should have a functioning installation.

Source: https://bugzilla.redhat.com/show_bug.cgi?id=1413191

  • On Fedora 30 and higher, you should skip the steps for disabling os-prober and grub2-mkconfig. Boot entries are now picked up according to the BootLoaderSpec, they're no longer in grub.cfg (so it's mostly static now and there's no point regenerating it). Also, disabling os-prober is potentially harmful. The step is there to stop grub2-mkconfig from detecting the live OS and adding a boot entry for it, but it also means that other OS installs on the machine (dual-boots) won't be detected and grub won't be able to boot them. – TooTea Jul 2 at 17:13
  • And if you decide to disable os-prober like this, you should at least re-enable it after the mkconfig to restore your system to the usual behaviour. If you don't, you've just broken your dual-boot and it may take you some head-scratching to realize why and how to fix it (chmod a+x /etc/grub.d/30_os-prober). – TooTea Jul 2 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.