0

I'm working on creating a ZFS zpool and I'm getting the following error:

# zpool create main_zfs raidz2 /dev/sdc /dev/sdd /dev/sde /dev/sdf /dev/sdg /dev/sdh /dev/sdi /dev/sdj /dev/sdk /dev/sdl /dev/sdm /dev/sdn /dev/sdo /dev/sdp /dev/sdq -f

the kernel failed to rescan the partition table: 16

cannot label 'sdc': try using parted(8) and then provide a specific slice: -1

I found another post on this subject here, but I can confirm that these disks have never been part of an MD array before.

Here's what I've tried so far:

  1. According to mount, none of these disks are currently mounted (they don't even have a file system anyway).

  2. I've used zpool labelclear /dev/sd[c-q] to erase any ZFS metadata from them.

  3. I've used dd to just zero the disks out.

7
  • Maybe name it mainzfs, without _. Dec 18, 2014 at 18:48
  • What does dmesg say after this command? Dec 18, 2014 at 18:48
  • Just tried naming it mainzfs.
    – Cameron
    Dec 18, 2014 at 18:56
  • Here's the dmesg: [2667947.877379] Creating zpool [2667958.300223] sdc: sdc1 sdc9 [2667958.350206] sdc: sdc1 sdc9
    – Cameron
    Dec 18, 2014 at 18:56
  • Did you reboot after dd? Dec 18, 2014 at 19:13

1 Answer 1

1

Put the -f right after the create.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .