1

I enabled the package e2fsprogs and always when the system starts it return the following error (when partition mounting):

Jan 01 00:00:03 xxxx systemd[1]: Found device /dev/mmcblk0p3.
Jan 01 00:00:03 xxxx systemd[1]: Starting File System Check on /dev/mmcblk0p3...
Jan 01 00:00:04 xxxx systemd-fsck[86]: read_bad_blocks_file: No such file or directory while trying to open -M
Jan 01 00:00:04 xxxx systemd-fsck[86]: fsck failed with error code 8.
Jan 01 00:00:04 xxxx systemd-fsck[86]: Ignoring error.

Apparently any problem occurs with the partition but i would like to know how to fix it and if this problem can cause some problem on the future.

/dev/mmcblk0p3 on /var type ext4 (rw,relatime,data=ordered)

  • What device is this? /dev/mmcblk0p3 is usually some form of flash storage. What filesystem is actually in use on it? Do mount and add the output to your question. – wurtel Dec 17 '14 at 12:47
  • /dev/mmcblk0p3 on /var type ext4 (rw,relatime,data=ordered) – Pedro Durek Dec 17 '14 at 12:52
  • 1
    It looks like systemd is invoking fsck with the wrong options. It's probably doing something like fsck -L -M ... where -L is interpreted as "the following argument is the file containing the list of bad blocks" and then -M is encountered. As -M is not a valid option for e2fsck the problem is in the way e2fsck is being called. Check the systemd config for fsck. – wurtel Dec 17 '14 at 12:59
  • [Unit] Description=File System Check on %f Documentation=man:systemd-fsck@.service(8) DefaultDependencies=no BindsTo=%i.device After=systemd-readahead-collect.service systemd-readahead-replay.service %i.device Before=shutdown.target – Pedro Durek Dec 17 '14 at 13:09
  • How can i change it (-M)? – Pedro Durek Dec 17 '14 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.