1

I installed a new Debian Linux 7.7 in a virtual machine (with bridged networking) on a Windows 7 host.

Now I am trying to get a tftp server running on it in order to supply an embedded device with a kernel and a device tree.

I installed xinetd, tftpd, and tftp. Then I setup a directory /srv/tftp, set the permissions on it, created /etc/xinetd.d/tftp.

Result: On the same machine I can access the tftp server (via its external IP) and get a file that I placed in /srv/tftp for testing purposes. On the Windows host of the VM I can ping the VM, but I cannot get anything via tftp because of a timeout.

As far as my researched showed the firewall on a new Debian Linux should be off by default.

iptables -L

shows three empty chains like

Chain INPUT (policy ACCEPT)

That should mean that all traffic is allowed, right?

googling "tftp only working for localhost" didn't yield any helpful results besides hints to check the firewall.

What else could be the problem?

Additional info:

netstat -unlp | grep -w :69

shows nothing (empty output).

Content of /etc/xinetd.d/tftp:

service tftp
{
protocol        = udp
port            = 69
socket_type     = dgram
wait            = yes
user            = nobody
server          = /usr/sbin/in.tftpd
server_args     = /srv/tftp
disable         = no
}

Additional info #2:

xinetd seems to be running.

Executing ps aux | egrep '[xi]netd' shows:

root      2954  0.0  0.0  19568   944 ?        Ss   08:27   0:00 /usr/sbin/xinetd -pidfile /var/run/xinetd.pid -stayalive -inetd_compat -inetd_ipv6
  • Does netstat -unlp | grep -w :69 show anything? Add the result to your question. – wurtel Dec 17 '14 at 12:51
  • Post the content of /etc/xinetd.d/tftp – Gilles Dec 17 '14 at 22:35
  • Sorry for the late addition of the infos. Didn't get it done before Xmas vacation. – DrP3pp3r Jan 12 '15 at 10:39
  • Are you sure the xinetd service is running? You should at least have xinetd listening the to port when you issue netstat -ulpn. – Spack Jan 12 '15 at 12:44
  • @Spack: updated my question – DrP3pp3r Jan 14 '15 at 7:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.