1

I'm using Debian 7.7 with the proprietary NVidia driver 319.82 and a GeForce 560Ti. This drives 2 portrait (rotated) monitors over DVI with no problem and I'm happy with the result.

I'd now like to add a 3rd portrait monitor. It seems like one can't mix NVidia and HD3000 GPUs, so presumably I'll have to buy another NVidia card. So which NVidia will work? Can I just buy any random cheap NVidia GPU (e.g., GeForce 210) and have it work? Or are there only particular combinations that are Linux-friendly?

(I'm not terribly concerned about rendering performance, OpenGL compliance level or SLI ability, so hopefully any card will do, and the only concern is compatibility. My only real requirement is that it can do 1200x1920 rotated over DVI, which I guess any modern-ish one will manage.)

  • seems silly that you should be so committed to driver v. 319.82 - any particular reason? – mikeserv Dec 16 '14 at 3:17
  • 1
    It's the one that's provided by the Debian package repository. – Tom Seddon Dec 16 '14 at 13:02
0

I threw caution to the wind and spent £26 on a Geforce GT610. The driver recognises it and it can drive a 3rd monitor. Best results, to my eyes, came after using nvidia-settings to configure each screen (including the two driven by the same GPU) as its own X display, then ticking the Xinerama box.

One general problem I've had after doing this:

  • Xinerama conflicts with the XRandR extension, so XRandR ends up disabled. This causes a lot of X programs to print a warning on startup, but it doesn't actually appear to cause any problems.

And two GNOME-related problems, which I suppose anybody else following along might also experience:

  • With Xinerama, GNOME runs in fallback mode, because Xinerama doesn't get on with Composite, which is an extension the fancy new GNOME shell requires. This has disabled a number of my GNOME shell extensions, but in general I think I'll get by.

  • GNOME got very confused as I was changing things around, and created 7 copies of the clock (and the logout menu, and the workspace switcher, and so on). To fix this, run dconf reset -f /org/gnome/gnome-panel/layout/ from the shell.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.