20

According to my browser (Firefox 34.0) the installed version of the Shockwave Flash plugin appears to be 11.2.202.424. This version is considered to be insecure:

The plugin is therefore blocked:

In the attempt to update the plugin to the version currently considered safe (11.2.202.425), I found out that the recommended version apparantly is already installed:

$ yum info flash-plugin
Loaded plugins: langpacks, refresh-packagekit
Installed Packages
Name        : flash-plugin
Arch        : x86_64
Version     : 11.2.202.425
Release     : release
Size        : 19 M
Repo        : installed
From repo   : adobe-linux-x86_64
Summary     : Adobe Flash Player 11.2
URL         : http://www.adobe.com/downloads/
License     : Commercial
Description : Adobe Flash Plugin 11.2.202.425
            : Fully Supported: Mozilla SeaMonkey 1.0+, Firefox 1.5+, Mozilla
            : 1.7.13+

My operating system:

$ cat /etc/redhat-release 
Fedora release 20 (Heisenbug)

My questions:

  • Do I have multiple versions of this plugin installed?
  • How can I fix my installation?
  • 8
    i dont think there is any such thing as secure flash – mikeserv Dec 14 '14 at 18:57
  • I also have the impression that Firefox already treats the Flash Plugin as dangerous when they might know about a security issue but no update is available yet. Then there's nothing you can do about it then, but at least flash is blocked on sites until there's an update. Just had this with 11.2.202.577. – Andy Apr 8 '16 at 8:36
27

I ran into this too, and found the answer in mozilla's bugzilla. In short, it happened because the plugin was updated while Firefox was running, and the pluginreg.dat got corrupted. So:

  1. exit firefox
  2. rm ~/.mozilla/firefox/*/pluginreg.dat
  3. start firefox again

and you'll be all set. (The file will be regenerated.)

Of course, you'll need to make sure that the .425 version is installed via yum update or other method. Presumably, this problem has been happening harmlessly for many updates — this is just the first where we all noticed it because of the blacklisting.

  • Worked great for me. The /usr/lib/flash-plugin/libflashplayer.so file for 11.2.202.425 is from 21/11/14 which is good, I thought firefox searched for this file but it was the registry indeed. – B2F Dec 17 '14 at 10:03
  • Well, still had the problem with 11.2.202.442. – B2F Feb 28 '15 at 15:40
3

I have tried rm ~/.mozilla/firefox/*/pluginreg.dat without any success, because in the addons page of firefox the flash plugin was still shown as vulerable with only the two options after it was newly generated: to deactivate or ask to activate.

I could solve the problem by editing the pluginsreg.dat which had the version number separated with comma instead of dots, even so i changed the description string:

Before:

[PLUGINS]
libflashplayer.so:$
/usr/lib/flash-plugin/libflashplayer.so:$
11,2,202,425:$
1416535783000:0:0:$
Shockwave Flash 11.2 r202:$
Shockwave Flash:$

After (working one):

[PLUGINS] 
libflashplayer.so:$
/usr/lib/flash-plugin/libflashplayer.so:$
11.2.202.425:$
1416535783000:0:0:$
Shockwave Flash 11.2.202.425:$
Shockwave Flash:$

After restarting firefox the flash plugin was set to always active in the addons page plugin config (all three options chooseable)

0

EDIT:

If you want modify all firefox profiles that are currently in use, you can use this simple script:

#!/bin/bash
for f in $(ps aux |grep "/usr/lib/firefox/firefox"| grep -v "grep" | head -1 |cut -d " " -f1); do 
        echo " * Found some firefox running .... updating pluginreg.dat"
        for d in $(find /home/${f}/.mozilla/ -name "pluginreg.dat"); do 
            echo " * Found ${d}"
            sed -i "s%11\.2\.202\.310%11\.2\.202\.425%g" ${d}
        done
done

In the sed sentence, you can modify the Version number of the FlashPlugin (11.2.202.310) to match your current version installed.

  • "Simple script"? I beg to differ. :P I think that for f in $(ps -C firefox -o user=); do will work perfectly enough :) Moreover, when I use your line, I find out that first line is the grep itself, and the firefox line I want is in line #2. So if you do want to go the complicated way, make sure you insert a | grep -v grep somewhere as well. – syntaxerror Dec 15 '14 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.