3

I use Vim Latex-Suite together with the PDF reader Zathura. In the last versions of Zathura they decided to output the following warning:

"warning: Failed to loads bookmarks"

whenever a document has no bookmarks defined (which is 99% of the time in my case).

The problem is that this warning goes to the standard output and for some reason when I call zathura from within vim, vim shows the warning over my buffer (I have to press Control+L to redraw the buffer).

Here is an example. Suppose I have this file:

http://diaz-caro.web.unq.edu.ar/inicial.png

After I call Zathura with <Leader>lv, Zathura opens and I get this:

http://diaz-caro.web.unq.edu.ar/final.png

My workaround was to make an script which calls zathura sending the standard and error output to /dev/null

zathura "$@" 2>/dev/null

Is there any elegant way to solve this problem? Why would vim output the warning in my buffer instead of hiding it or outputting it in another buffer as it does with LaTeX errors?

migrated from tex.stackexchange.com Dec 14 '14 at 15:43

This question came from our site for users of TeX, LaTeX, ConTeXt, and related typesetting systems.

  • Any success with such issue? – petRUShka Apr 15 '15 at 17:28
  • No :( I continue with the workaround mentioned in the post. – Alejandro DC Apr 15 '15 at 21:46
1

You can use

zathura -l error file.pdf

to turn off the warning message. But it is similar to what you have, :).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.