10

I updated my Ubuntu Linux to 14.04 and now the mouse and keyboard don't work in the login screen. I tried re-installing grub from a Live USB, but it's still not working. I would really appreciate your help.

  • does the keyboard work before the boot loader, when it is controlled by the BIOS ?, like to hit del, f2 or whatever to enter setup... – Grady Player Dec 13 '14 at 20:07
  • yes it does. It doesn't work only in login screen. – Ivana Dec 13 '14 at 20:10
  • I also have installed Windows 7 Ultimate, and I don't have any problems login in that SO. – Ivana Dec 13 '14 at 20:11
  • Do the Mouse and Keyboard work in a normal Terminal? Press Ctrl + Alt + F3 at the login screen, then try logging in. – eyoung100 Dec 13 '14 at 20:30
  • I press Ctrl + Alt + F3 at the login screen but doesn't work. – Ivana Dec 13 '14 at 20:36
15

Reinstall input device drivers

sudo apt-get install --reinstall xserver-xorg-input-all
  • 2
    I just did it, but still not working. – Ivana Dec 13 '14 at 20:25
  • 1
    Have you updated your system with sudo apt-get update && sudo apt-get upgrade ? I found there was some bug that could cause it. – kirill-a Dec 13 '14 at 20:53
  • How can she do that if she can't login? – eyoung100 Dec 13 '14 at 21:35
  • 1
    Thanks for your answers! I try update and upgrade booting with a ubuntu live ubs. But it still not working. – Ivana Dec 13 '14 at 22:09
  • 1
    Can you login with recovery mode? When grub is showing list of options, there should be recovery mode for ubuntu. – kirill-a Dec 14 '14 at 8:40
2

half-way fix: reboot, choose in boot menu older kernel, boot it. keyboard and mouse works. then you can login and fix your configs. ps: if you can not boot anymore (cause you kill your grub) then only one way to fix: you must make boot usb flash drive and boot from it. then mopunt your HDD and backup/fix your configs.

1

Boot into recovery mode, hold shift after the BIOS loads.

Select the second kernel with (recovery mode). If you still have the same problem, mouse/keyboard not responding then reboot and try again with the next available recovery mode kernal. I have once had to use the third option before it worked.

Turn on networking network then fix the packages dpkg. Once complete resume. The video drivers may be wonky, either way reboot.

Keyboard and mouse should be working again.

  • What if no options work? – KillerSnail Mar 2 '17 at 15:11
  • Unable to start network, therefore dpkg doesn't work !! – user391339 Mar 2 '18 at 5:51

protected by Community Apr 10 '15 at 13:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.