2

I am using LXDE as my desktop environment (on Debian Wheezy). My question is related to how mouse behaves in LXDE, but could be general to other desktop environments.

When I double click with my mouse on any text, the whole word is selected. However, when the word contains @, only the first part is selected (@ acts as word separator). I.e, when I double click on the following text, only "martin" will be selected.

martin@asdf.com

I don't know where this is configured.

Is it possible to change it, so that only white space acts as separator? I want to select the whole email address when I double click on it.

  • 2
    This depends on the application, not on the desktop environment. Which application(s) do you want to tune? – Gilles Dec 13 '14 at 21:14
  • For example in Terminator and Leafpad – Martin Vegter Dec 13 '14 at 21:17
  • 1
    You can change this behavior for terminator by going to Preferences -> Profiles -> General and change the value Select-by-word characters from -A-Za-z0-9,./?%&#:_ to -A-Za-z0-9,./?%&#:_@ by adding an @ to the end. I don't use Leafpad so I can't help you there. But it is a per app issue as Gilles mentioned. – Raphael Ahrens Dec 16 '14 at 6:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.