0

We have a NAS server in the lab and I can reach it through the web interface at 192.168.1.100, and I have enabled NFS on the admin's panel.

enter image description here

After that I did

sudo aptitude install nfs-common
sudo mount -t nfs4 192.168.2.254:/gwas_data /media/thecus

Result:

mount.nfs4: Connection timed out

OS is Ubuntu 14.04. Any ideas?

4
  • 4
    Tried replacing the IP address with your NAS's actual IP?
    – Mat
    Dec 11, 2014 at 13:24
  • Possibly your firewall blocks the ports necessary for NFS (and maybe also rpcbind). Have a look at dmesg | tail right after trying the mount command.
    – Ned64
    Apr 28, 2017 at 10:00
  • thecus OS5 or 6- slight changes to os7. hope it helps.
    – jmazzmans9
    Jun 6, 2019 at 2:53
  • 1
    Also check the NFS version supported by the NAS. Sometimes they don't do NFSv4 so you may need to enable NFSv3 support client-side.
    – Ned64
    Aug 3, 2020 at 15:05

1 Answer 1

0
  1. Create a public folder (FMBData in this example)
  2. Click on NFS to share it
  3. Set the hostname to the IP of the linux machine (e.g. 192.168.1.111)
  4. On the linux machine, sudo apt-get install nfs-common, sudo mkdir /media/thecus, then sudo mount -t nfs4 192.168.1.100:FMBData /media/thecus. You can get the WAN IP of the server on the front screen.

Screenshots:

enter image description here

enter image description here

1
  • Maybe you could detail which NAS this is for - there are several brands and firmware revisions and thiis question and answer is very specific.
    – Ned64
    Apr 28, 2017 at 10:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .