Running Easy Peasy 1.6 clean installation. Hardware - EEE PC 900-HA.

About 10 or so minutes into a new session after a reboot my mouse will stop working. It will still move the pointer, but it will no longer register clicks correctly. The behavior is very strange.

For instance I can be clicking in either a firefox window or on the tab bar. If I clear the cache it will allow me to switch.

Often if there are multiple windows open clicking will only switch between the windows and will not register the click in either window.

The behavior is incredibly erratic. I have tried a clean installation of Easy Peasy 1.6 and also attempted to reinstall input-attach.

UPDATE: my clean installation ran through a bunch of updates last night and the mouse worked for a while, but still started to stop working after 30-60 minutes. I tried letting it sit after logging on and it still just worked for a few minutes and then stopped. Any ideas, thinking about switching flavors if I can't figure it out soon.

Update 2:

When it works:

KeymapNotify event, serial 31, synthetic NO, window 0x0,
     keys:  11  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
            0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

ButtonPress event, serial 31, synthetic NO, window 0x3e00001,
     root 0x10b, subw 0x0, time 55427, (263,134), root:(263,158),
     state 0x0, button 1, same_screen YES

ButtonRelease event, serial 31, synthetic NO, window 0x3e00001,
     root 0x10b, subw 0x0, time 55531, (263,134), root:(263,158),
     state 0x100, button 1, same_screen YES

When it doesn't:

no alt-tab

Sorry for the image, but alt-tab seems to break too. Pretty sure the keypress event is when I clicked into the window, but I'm not sure of it. If that isn't enough I can try it again and try to get it to copy, can't seem to get the edit menu to open when it's acting up.

  • By "mouse", do you mean the built-in touchpad, or have you connected an external mouse to your system?
    – cjm
    Commented Jul 25, 2011 at 1:20
  • @cjm - same behavior with both the touch pad and an external wireless USB mouse. as well as a wired USB mouse.
    – wax eagle
    Commented Jul 25, 2011 at 1:22
  • Does it stop working sooner based on the amount of mouse movement? Like, if you leave it running for 10 minutes before moving the mouse, does it still freeze? Commented Jul 25, 2011 at 8:25
  • @amphetamachine - I think that if I leave it and bring it up a few minutes later the mouse still works for a short period of time. The login screen seems hesitant to come up after sleep as well. Not sure if its related. I will confirm this when I get home later today.
    – wax eagle
    Commented Jul 25, 2011 at 11:22
  • 1
    Run the program xev from a terminal. At the beginning of the session, while the mouse is still working, move the mouse into the xev window and click in it. Copy-paste the output resulting from your click (a ButtonPress event and a ButtonRelease event) to a file. Later, when the mouse isn't working, repeat the experiment. Add both reports from xev to your question. Commented Jul 26, 2011 at 20:01

1 Answer 1


The xev output shows a KeyPress event for the Alt_L key with state 0x400. The state indicates which key modifiers and mouse buttons are down immediately before the event, e.g. state 0x1 would indicate that Shift was down, state 0x4 that Control was down, etc. state 0x400 indicates that Button3 (the right mouse button) is down.

What's happening is that your system thinks you're still holding the right mouse button down. This prevents a lot of keyboard and mouse shortcuts from working.

When the problem occurs, try clicking the right mouse button. If what is causing the events to be dropped is sporadic, this will send a ButtonRelease event and all will be well again, until the next dropped event.

At this point I don't know what could be causing the problem. Try logging in with a test account and working for a while, to see if it's related to some program you're running in your account. Look in /var/log/kern.log for suspicious messages (I don't know what the messages would look like; normally this file gets a lot of messages at boot time and not many afterwards, you may want to post the part of the file after the end of the boot process so that someone can look at it).

When the problem occurs, run xev and observe the events sent by the mouse. Clicking on a button in the xev window should send a ButtonPress event followed by a ButtonRelease. Pressing a key should send KeyPress followed by KeyRelease. The state value should always be 0x0 when you don't have a modifier or button pressed. If you always see 0x400, it means that your system is specifically dropping right mouse button releases. If you sometimes see 0x100 or 0x200 when the problem occurs, it means your system is dropping left and middle releases too.

  • Not sure what is meant by "you may want to part of the file". This may be a typo. Commented Jul 27, 2011 at 18:05
  • @FaheemMitha [status-completed] Commented Jul 27, 2011 at 18:07
  • @Gilles - this is exactly what was happening. Pretty sure its a hardware issue Disabling the touchpad on the netbook has solved the problem. Looks like the right click key is jammed or at least it thinks its jammed.
    – wax eagle
    Commented Jul 30, 2011 at 17:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .