1

I am having Nvidia GEFORCE 610m graphic card.

whenever i install nvidia drivers in mint cinnamon 17.1 my cinnamon crashes and my cinnamon goes in fallback mode !!

SO how can i install bumblebee in Mint 17.1 ?

2 Answers 2

1

UPDATE instead of 331 version, check what's current version of nvidia-current package. You can install it and see the version or just google this name and your distribution to check what's in repositories.

Have you followed this steps?

1) Open a terminal. Install Bumblebee and the NVIDIA driver:

sudo apt-get update

sudo apt-get install bumblebee bumblebee-nvidia bbswitch-dkms primus nvidia-331

2) Change Bumblebee’s configuration:

sudo gedit /etc/bumblebee/bumblebee.conf

3) Edit the lines so they match the lines below:

[driver-nvidia]

KernelDriver=nvidia-331

LibraryPath=/usr/lib/nvidia-331:/usr/lib32/nvidia-331

XorgModulePath=/usr/lib/nvidia-331/xorg,/usr/lib/xorg/modules

4) Save the file

5) Restart your computer

6) Test if it’s working (you should get a high FPS):

vblank_mode=0 glxgears
4
  • I assume this 331 is a different number depending on your system? Or whatever is the latest available?
    – donquixote
    Jun 11, 2016 at 22:06
  • I have nvidia-304 installed. I think this came from nvidia-current. nvidia-340 is also available.
    – donquixote
    Jun 11, 2016 at 22:13
  • Yes, when I wrote this answer, 331 was the latest version. I'll change my answer to be up-to-date.
    – kirill-a
    Jun 14, 2016 at 9:09
  • The settings I already have say "nvidia-current" everywhere instead of "nvidia-331". I suppose this also works.
    – donquixote
    Jun 14, 2016 at 22:55
0

I had this same issue - crashing and getting an error about Xclient or Xserver after installing nvidia. I had to remove nvidia to get the system working again. I figured out a fix. I recommend doing this before you even try to install the nvidia drivers:

In Mint go to Menu, then Administration, then Login Window. In Login Window Preferences select Options. At the top, the Default session is probably Run Xclient script. Change it to Cinnamon. Then reboot. Then install your nvidia and it should work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .